Subject: Re: Reminder: Please fill out our survey on IETF authoring tools

From: Antonio Diaz Diaz <[email-masked]>
Date: Mon, 02 Nov 2020 12:22:15 +0100

Dear Director,

IETF Executive Director wrote:
> The IETF is conducting a survey to help us understand what tools and formats you use for authoring IETF Internet Drafts (I-Ds), how you use them and what more you need from them.  The data from this survey is vital for our future planning of tools investment.
>
> This note is to thank the 270 of you that have responded to this survey so far and to remind those of you that haven't to please spare a few minutes to fill out the survey, even if you do not author I-Ds any more:
>
> 	https://ietf.iad1.qualtrics.com/jfe/form/SV_8d21RFqe5dBijOJ
>
> Your email address has been selected because you have been listed as the author or submitter of an I-D in the last five years.  The survey is anonymous - we only record the data you provide and do not record your IP address or any details of your computer.

It would be a pleasure for me to dedicate more than a few minutes to help 
the IETF as long as I do not need to enable javascript in my browser to do 
it. Sadly the page above requires it to the point that the browser just 
shows the message: "Javascript is required to load this page."

I'll be glad to fill out any IETF survey if it can be done without javascript.

In case it is useful, I answer here your questions.

1) What tools and formats you use for authoring IETF Internet Drafts (I-Ds)?

   I use a text editor to write the draft in plain text format.

   I use the idnits tool offline (not through a webpage) to check the draft. 
http://tools.ietf.org/tools/idnits

   I use the Internet Draft Submission Tool to submit the draft. 
http://datatracker.ietf.org/submit/

2) How do you use them and what more you need from them.

   Both tools are straightforward to use, and I think they fulfill all my needs.

Best regards,
Antonio.

---

From: Nick Hilliard <[email-masked]>
Date: Mon, 2 Nov 2020 14:38:44 +0000

> I'll be glad to fill out any IETF survey if it can be done without 

I'm ok with JS, but the company IT policy includes bits on installing 
browser add-ons to block online tracking.  These add-ons don't work with 
Qualtrics surveys, so all I see is a spinning circle.

Nick

---

From: Jay Daley <[email-masked]>
Date: Tue, 3 Nov 2020 06:57:55 +1300

Hi Antonio

> On 3/11/2020, at 12:22 AM, Antonio Diaz Diaz <[email-masked]> wrote:
> 
> Dear Director,
> 
> It would be a pleasure for me to dedicate more than a few minutes to help the IETF as long as I do not need to enable javascript in my browser to do it. Sadly the page above requires it to the point that the browser just shows the message: "Javascript is required to load this page."

I think we reached a point some years ago where it became impossible to provide a good web experience without javascript.

>  I use the idnits tool offline (not through a webpage) to check the draft. http://tools.ietf.org/tools/idnits
> 
>  I use the Internet Draft Submission Tool to submit the draft. http://datatracker.ietf.org/submit/
> 

Thank you for providing that but unfortunately I won’t be able to use these without the answers to the rest of the questions.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Jay Daley <[email-masked]>
Date: Tue, 3 Nov 2020 07:39:31 +1300

Hi Nick

> On 3/11/2020, at 3:38 AM, Nick Hilliard <[email-masked]> wrote:
> 
> I'm ok with JS, but the company IT policy includes bits on installing browser add-ons to block online tracking.  These add-ons don't work with Qualtrics surveys, so all I see is a spinning circle.

I’ve looked at this based on your earlier report and while occasional problems have been reported with both Ghostery and AdblockPlus, it’s not clear if either is at fault here.  In response to your previous request "Can you ensure that future surveys work with common browser add-ons? Qualtrics are unusually prone to problems in this area." I’m afraid that’s not possible for two reasons.  One is that these addons can be configured in many different ways with various combinations of rulesets and so testing that is not possible, and the second is that Qualtrics is by far the best survey system I’ve so far encountered and I would not want to downgrade unless there were a major problem that could not be fixed.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: "[email-masked]" <[email-masked]>
Date: Mon, 2 Nov 2020 22:54:51 +0000 (UTC)

> if it can be done without javascript.

Javascript isn't an IETF standard.

On the other hand, IPv6 *is* an IETF standard,
but as far as I can tell, this survey website
(or rather, its cloud instantiation) is not
using that.

L.

we need a World IPv6 Survey Day.

Lloyd Wood [email-masked] http://about.me/lloydwood

---

From: Nick Hilliard <[email-masked]>
Date: Mon, 2 Nov 2020 23:22:17 +0000

Jay Daley wrote on 02/11/2020 18:39:
> I’ve looked at this based on your earlier report and while occasional 
> problems have been reported with both Ghostery and AdblockPlus, it’s not 
> clear if either is at fault here.  In response to your previous request 
> "Can you ensure that future surveys work with common browser add-ons? 
> Qualtrics are unusually prone to problems in this area." I’m afraid 
> that’s not possible for two reasons.  One is that these addons can be 
> configured in many different ways with various combinations of rulesets 
> and so testing that is not possible, and the second is that Qualtrics is 
> by far the best survey system I’ve so far encountered and I would not 
> want to downgrade unless there were a major problem that could not be fixed.

the problem was apparently related to Ghostery smart blocking.  If smart 
blocking is enabled, the ietf survey site works ok; if it's disabled, it 
doesn't work.

I understand your take on this from the point of view of tooling 
functionality. Conversely, from the end user point of view, you're 
already making an ask for our time to fill out a survey, so if there's 
another hoop to jump through, e.g. having to load the site on a VM / 
someone else's computer / debug root cause / etc, that's often going to 
be enough to cause people to sigh and delete the email, and then no-one 
wins.

Maybe you could raise the issue with Qualtrics and ask them to fix the 
problem? It's fully repeatable.

Nick