Subject: Re: Looking for a grammar/spelling tool for XML I-D

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Mon, 16 Nov 2020 13:10:13 +0000

For information, there is now a list of tools to check grammar (in addition to spelling) in XML formatted IETF drafts.

The list is on this public IESG wiki page: https://trac.ietf.org/trac/iesg/wiki/GrammarCheckingID

Hope this helps and comments/suggestions/additions are welcome

Have a wonderful, error free, IETF-109 ;-)

-éric

From: Eric Vyncke <[email-masked]>
Date: Thursday, 20 August 2020 at 15:38
To: "[email-masked]" <[email-masked]>
Subject: Looking for a grammar/spelling tool for XML I-D

Written by a non-English speaker...

The IESG believes that the I-D review (in last call, in IESG telechat, ...) could be improved for some documents if the grammar was correct and typos absent (and I plead guilty to do typos in my documents). Easier said than done of course.

Most modern word processors have this feature but I know about no tools able to do this check on .XML or .TXT...

So, we are looking forward for any tools on-line/off-line being able to do this. It could be a tool-chain built on GNU aspell or course (but aspell does not check grammar) or via an API to https://languagetool.org/ .

Henrik wrote https://tools.ietf.org/tools/idspell/idspell.pyht but is dated 2007 and we could probably do better in 2020 ;-)

Thank you for pointers, suggestions, comments

-éric

---

From: Adam Roach <[email-masked]>
Date: Tue, 17 Nov 2020 01:23:15 -0600

Incidentally, running aspell with the "-H" flag works just fine for 
spell-checking XML sources. This is what I've done for years.

/a

On 11/16/2020 7:10 AM, Eric Vyncke (evyncke) wrote:
>
> For information, there is now a list of tools to check grammar (in 
> addition to spelling) in XML formatted IETF drafts.
>
> The list is on this public IESG wiki page: 
> https://trac.ietf.org/trac/iesg/wiki/GrammarCheckingID
>
> *From: *Eric Vyncke <[email-masked]>
> *Date: *Thursday, 20 August 2020 at 15:38
> *To: *"[email-masked]" <[email-masked]>
> *Subject: *Looking for a grammar/spelling tool for XML I-D
>
> The IESG believes that the I-D review (in last call, in IESG telechat, 
> ...) could be improved for some documents if the grammar was correct 
> and typos absent (and I plead guilty to do typos in my documents). 
> Easier said than done of course.
>
> Most modern word processors have this feature but I know about no 
> tools able to do this check on .XML or .TXT...
>
> So, we are looking forward for any tools on-line/off-line being able 
> to do this. It could be a tool-chain built on GNU aspell or course 
> (but aspell does not check grammar) or via an API to 
> https://languagetool.org/ .
>
> Henrik wrote https://tools.ietf.org/tools/idspell/idspell.pyht but is 
> dated 2007 and we could probably do better in 2020 ;-)
>

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 17 Nov 2020 10:56:38 -0600

> spell-checking XML sources. This is what I've done for years.

I installed aspell on my Macbook.
But I am getting
Error: Unknown mode: "html"

with -H option.

It says I need some files in /usr/lib/aspell
which I don't have.

Behcet

>
>
> -éric
>
>
>
> *From: *Eric Vyncke <[email-masked]> <[email-masked]>
> *To: *"[email-masked]" <[email-masked]> <[email-masked]> <[email-masked]>
> ...) could be improved for some documents if the grammar was correct and
> typos absent (and I plead guilty to do typos in my documents). Easier said
> than done of course.
>
>
>
> So, we are looking forward for any tools on-line/off-line being able to do
> this. It could be a tool-chain built on GNU aspell or course (but aspell
> does not check grammar) or via an API to https://languagetool.org/ .
>
>
>