Subject: Fisking vs Top-Posting

From: Phillip Hallam-Baker <[email-masked]>
Date: Mon, 20 Sep 2010 14:20:03 -0400

One of the problems I have seen emerge on many IETF mailing lists is the
habit of fisking.

By fisking I mean responding to a post  line by line *while reading it for
the first time*.

Now sometimes a line by line response is entirely appropriate. If someone
raises six different issues, you want to respond to each one separately. But
other times I see posts of the following form:

> We should buy the red van

Are you crazy, the last three vans were yellow. Only an idiot would buy a
red van (etc)

> Because even though yellow is traditional the red one is on sale for $1000
off.

I seem to be reading an increasing number of posts on various lists where it
is very clear to me that the poster did not bother to read the entire
message before starting their reply. In particular I have read rather a lot
of people starting off by accusing their opponent of being ignorant of
issues that their opponent actually states only a few paragraphs further on.

Traditionally, top-posting (or bottom posting) has been discouraged in favor
of responding line by line. I think it is time to reverse that preference.

In particular I find that arguments are often less combative and somewhat
shorter in mediums where people are forced to restate the issue they are
objecting to in their own words.

-- 
Website: http://hallambaker.com/

---

From: Dave Cridland <[email-masked]>
Date: Mon, 20 Sep 2010 23:07:25 +0100

> of responding line by line. I think it is time to reverse that  
The primary argument in favour of inline responses is that they allow  
context to be retained. I certainly agree that if the responder  
doesn't actually take that context into account when responding then  
this advantage is quite obviously lost, but throwing away that  
advantage does not strike me as a particularly useful tactic.

> objecting to in their own words.

One thing I noted in your post was the use of the term "opponent".  
Now, this is itself a combative term, but I suspect you meant it in  
the sense of a debating opponent, and you're implying by that usage,  
and quite clearly expressing in the above, a call to rhetoric. In  
other words, you're not actually criticising the *content*, or  
technical merit, of the arguments but the way they're expressed.  
Given the large porportion of IETF participants who somehow failed to  
join debating clubs at exclusive universities, this disquiets me  
somewhat.

Now, I'm all in favour of people avoiding being combative. But I  
would far rather be shot down in flames than have my crazier ideas  
accepted politely for fear of offense.

Secondly, an argument to ignore the benefits of a medium that the  
participants here created seems entirely odd - surely we should  
simply strive to use it *better*, rather than abandoning it?

Dave.
-- 
Dave Cridland - mailto:[email-masked] - xmpp:[email-masked]
  - acap://acap.dave.cridland.net/byowner/user/dwd/bookmarks/
  - http://dave.cridland.net/
Infotrope Polymer - ACAP, IMAP, ESMTP, and Lemonade

---

From: Scott Brim <[email-masked]>
Date: Mon, 20 Sep 2010 18:49:19 -0400

I take your point that the whole message should be read before replying.
 Thank you.  However, one can top-post and bottom-post without reading a
message just as well as one can when interleaving a reply :-).  Reply
style is separate from the first issue (people should read their mail
fully), because how one replies really depends on what one is trying to
accomplish.

btw top-posting is not the spawn of evil demons, it's perfectly
appropriate in some situations, e.g. this one, where the original mail
is just attached for possible reference.

swb

On 09/20/2010 14:20 EDT, Phillip Hallam-Baker wrote:
> By fisking I mean responding to a post  line by line *while reading it
> for the first time*.
> 
> Now sometimes a line by line response is entirely appropriate. If
> someone raises six different issues, you want to respond to each one
> separately. But other times I see posts of the following form:
> 
> Are you crazy, the last three vans were yellow. Only an idiot would buy
> a red van (etc)
> 
>> Because even though yellow is traditional the red one is on sale for
> $1000 off.
> 
> I seem to be reading an increasing number of posts on various lists
> where it is very clear to me that the poster did not bother to read the
> entire message before starting their reply. In particular I have read
> rather a lot of people starting off by accusing their opponent of being
> ignorant of issues that their opponent actually states only a few
> paragraphs further on.
> 
> 
> Traditionally, top-posting (or bottom posting) has been discouraged in
> favor of responding line by line. I think it is time to reverse that
> preference.
> 
> In particular I find that arguments are often less combative and
> somewhat shorter in mediums where people are forced to restate the issue
> they are objecting to in their own words.
> 
> -- 
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf

---

From: John Leslie <[email-masked]>
Date: Mon, 20 Sep 2010 19:59:13 -0400

> is just attached for possible reference.

   Aha!

   (Scott can take care of himself without feeling the need to retaliate;
so I'll respond to his email...)

   Top-posting which copies the _entire_ post being responded to is
definitely the spawn of evil demons!

   It's also incredibly annoying to those of us trying to follow high-
bandwidth lists like this one.

   Fortunately, I can see 80 lines at a glance as I read this list in
"mutt"; so it's not Scott's mail which annoys me -- it's the ones where
two folks go back and forth without ever trimming the part "quoted for
possible reference", and I can't remember whether _both_ of them top-
post.

   Folks, please:

   Let's not quote entire emails "for possible reference" in a high-
volume list. Those of us worth reaching know how to use threaded
email clients, and we can _very_ easily find the message you're
replying to.

   Better yet, don't quote any more than the bare minimum to set context,
whether you top-post, bottom-post, or respond inline.

   (Myself, I find it much easier to follow in-line comments, so I take
the effort to post that way. I'll be happy to pay attention to private
emails cricicizing me for this, but I _will_not_ participate in a
public flame-war about how dreadful this practice is.)

--
John Leslie <[email-masked]>

---

From: Randy Dunlap <[email-masked]>
Date: Mon, 20 Sep 2010 17:04:20 -0700

> bandwidth lists like this one.

IETF is high bandwidth?  ;)

Hint:  try Linux kernel development mailing lists.

> public flame-war about how dreadful this practice is.)

I see $subject only as personal preference, nothing else.
(does that get retaliation?)

---
~Randy

---

From: Nathaniel Borenstein <[email-masked]>
Date: Tue, 21 Sep 2010 09:44:52 +0100

On Sep 20, 2010, at 7:20 PM, Phillip Hallam-Baker wrote:

> One of the problems I have seen emerge on many IETF mailing lists is the habit of fisking.

Please clarify what you mean by fisking.

> By fisking I mean responding to a post  line by line *while reading it for the first time*.

Thanks.  And why is this a bad thing, in your view?

> I seem to be reading an increasing number of posts on various lists where it is very clear to me that the poster did not bother to read the entire message before starting their reply.

Perhaps they're just very busy people?  Are you too ignorant to have thought of that?

> In particular I have read rather a lot of people starting off by accusing their opponent of being ignorant of issues that their opponent actually states only a few paragraphs further on.

Reading ahead is hard, you can't expect everyone to do it.  Many of us are too busy and important to take the time to compose a message carefully, so it makes sense to require everyone else to take longer to read our messages.

> Traditionally, top-posting (or bottom posting) has been discouraged in favor of responding line by line. I think it is time to reverse that preference.

You can't tell me what to do; that's what the Nazis did.  You suck.

> In particular I find that arguments are often less combative and somewhat shorter

Is that a crack about my height?  I dare you to say it to my face at the next IETF.  

> in mediums where people are forced to restate the issue they are objecting to in their own words.

In all seriousness, forcing any particular approach is the real issue.  I can't imagine how it would be accomplished.  What I'd really like to force people to do is be more thoughtful and restrained; if they did that, it wouldn't much matter what approach they took to replies.  -- Nathaniel

PS for the humor impaired -- only my last paragraph was intended to be serious.  -- nsb

---

From: Sabahattin Gucukoglu <[email-masked]>
Date: Tue, 21 Sep 2010 12:54:30 +0100

> Thanks.  And why is this a bad thing, in your view?

[Snip the rest of this brilliant and audacious take.]
You, sir, are owed a beer.  And I am owed a new keyboard, because the coffee I was drinking is suddenly and mysteriously absent from both my cup and my stomach ...
> In all seriousness, forcing any particular approach is the real issue.  I can't imagine how it would be accomplished.  What I'd really like to force people to do is be more thoughtful and restraine…

+1.  I do generally prefer an in-line style, and that because I wish to give full attention to the post and leave no chance of ambiguity - but I accept the utility of top-posting, on very, very rare occasions.  In particular, high-volume blindness-only lists tend to prefer top-posting heavily because the readers can get quickly to the answers using linear top-down reading by speech synthesis.  (No doubt it is not a coincidence that I am on very few such lists.)

> PS for the humor impaired -- only my last paragraph was intended to be serious.  -- 

Oh, and now you've gone and ruined it. :-)

Cheers,
Sabahattin

---

From: Jorge Amodio <[email-masked]>
Date: Tue, 21 Sep 2010 07:08:30 -0500

Fisking ... it sounds naughty :-). No blogger jargon aqui (I mean me).

J

---

From: todd glassey <[email-masked]>
Date: Tue, 21 Sep 2010 05:49:55 -0700

> Perhaps they're just very busy people?  Are you too ignorant to have thought of that?

The real issue here is that this is a mailing list and synchronization
of messages is nearly impossible through the IETF lists as they exist.
As a result of this really stupid, stone-age methodology any number of
issues including this one arise.

The really pompous issue here for IETF management to address is why they
 and the rest of the "Idiots" as you call them above want this to
continue when something as stupid as a LINKEDIN WG would satisfy most
all of the WG issues. Hell even using something like Wordpress would be
better that what is here now.

But you also have to realize that the Professional Standards Lifers -
those people who make Standards their commercial business - dont want
this to change. They want things to stay just like they are to protect
this aspect of their employment and in this day and age its really
understandable - unethical and pretty slimy in my personal opinion, but
I think that of most people who make their business that of creating
standards and blocking others, which is something rampant here in the IETF.

> Reading ahead is hard, you can't expect everyone to do it.  Many of us are too busy and important to take the time to compose a message carefully, so it makes sense to require everyone else to take…
Yes - too busy to actually participate - what an amazing realization...

> No virus found in this incoming message.
> Checked by AVG - www.avg.com 
> Version: 9.0.851 / Virus Database: 271.1.1/3148 - Release Date: 09/20/10 10:04:00
> 

-- 
//-----------------------------------------------------------------

This message may contain confidential and/or privileged information.
If you are not the addressee or authorized to receive this for the
addressee, you must not use, copy, disclose or take any action based
on this message or any information herein. If you have received this
message in error, please advise the sender immediately by reply e-mail
and delete this message.

Thank you for your cooperation.

---

From: todd glassey <[email-masked]>
Date: Tue, 21 Sep 2010 05:51:55 -0700

> standards and blocking others, which is something rampant here in the IETF.

are guilty of this at one time or another.

---

From: Keith Moore <[email-masked]>
Date: Tue, 21 Sep 2010 10:40:41 -0400

> Fisking ... it sounds naughty :-). No blogger jargon aqui (I mean me).

I'll admit it...I was really disappointed to learn how Phillip had defined that word.  I think the word should be reserved for something naughtier.

And yes, top posting really is inherently evil. :)  There's no need to quote an entire (long) message for context, that's what the In-Reply-To field is for.

---

From: Jorge Amodio <[email-masked]>
Date: Tue, 21 Sep 2010 09:48:03 -0500

Well afaik we should ask Robert Fisk about it.

But Phillip has the tendency to also post comments (top, bottom,
inline, sideways and upside down)  without reading the source he is
making the comment about, like @CircleID regarding Beckstrom's book
"The Starfish and Spider" (read the book it's quite interesting).

Perhaps we'll get a better picture about "fisking" with a video blog ...

Cheers
J

PS. Upps I top posted, sorry :-S

---

From: Randy Dunlap <[email-masked]>
Date: Tue, 21 Sep 2010 08:28:17 -0700

> issues including this one arise.

I don't see a problem with mailing lists in general, just with the
sometimes large delays (moderated lists?) that (at least) [email-masked] uses.

I was not the addressee.  Deleted.

---
~Randy
*** Remember to use Documentation/SubmitChecklist when testing your code ***

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Mon, 20 Sep 2010 19:05:08 -0400

I agree that regarding the other poster as an 'opponent' is bad. This is
meant to be a consensus based organization, not a debating society where
form is more important than substance and the objective is to score points.
That is kinda what I was trying to get at.

Line by line comments certainly have their use, but maybe someone
occasionally needs to call a time out on that approach when people are using
it to talk past each other.

On Mon, Sep 20, 2010 at 6:07 PM, Dave Cridland <[email-masked]> wrote:

>> favor
> context to be retained. I certainly agree that if the responder doesn't
> actually take that context into account when responding then this advantage
> is quite obviously lost, but throwing away that advantage does not strike me
> as a particularly useful tactic.
>
>
>
> One thing I noted in your post was the use of the term "opponent". Now,
> this is itself a combative term, but I suspect you meant it in the sense of
> a debating opponent, and you're implying by that usage, and quite clearly
> expressing in the above, a call to rhetoric. In other words, you're not
> actually criticising the *content*, or technical merit, of the arguments but
> the way they're expressed. Given the large porportion of IETF participants
> who somehow failed to join debating clubs at exclusive universities, this
> disquiets me somewhat.
>
> Now, I'm all in favour of people avoiding being combative. But I would far
> rather be shot down in flames than have my crazier ideas accepted politely
> for fear of offense.
>
> participants here created seems entirely odd - surely we should simply
> strive to use it *better*, rather than abandoning it?
>
> Dave.
> --
> Dave Cridland - mailto:[email-masked] - xmpp:[email-masked]<[email-masked]>

---

From: Wes Hardaker <[email-masked]>
Date: Tue, 21 Sep 2010 07:43:57 -0700

>>>>> On Mon, 20 Sep 2010 14:20:03 -0400, Phillip Hallam-Baker <[email-masked]> said:

PH> One of the problems I have seen emerge on many IETF mailing lists is the
PH> habit of fisking.

This could all be solved by moving IETF discussions to Google Wave.
Then I could start responding to your thought even before you finished
typing it.
-- 
Wes Hardaker
Cobham Analytic Solutions

---

From: "Polk, William T." <[email-masked]>
Date: Tue, 21 Sep 2010 11:11:43 -0400

This is the sort of thread I usually don't respond to, but we have this debate about top-posting so often I just can't resist this time.  (Must have been something in my coffee.)

Personally, I don't care whether people bottom-post, top-post, or comment in-line.   What I dearly wish for (but do not expect to ever get) is consistency.

At least two or three times a week, someone forwards me an email thread with 8 or 9 embedded messages that works out to six or seven hundred lines of text.  A couple were top-posted, a couple bottom-posted, and the remainder inserted comments in-line.  Yuck.  Trying to follow the conversation at that point is incredibly confusing.  Start at the top, jump to the bottom, oh, this one is in-line... Now my head hurts, I need more coffee, and I still haven't figured out the point of this stupid thread.

I should note that this sort of mess would be easiest if everyone bottom-posted (because I could just read the mess in order) but consistent top-posting or commenting in-line can be followed fairly reasonably as well.  So, I propose the following etiquette: first responder chooses the style (e.g., in-line, top-post, bottom-post).  Anyone that responds to *that* email should follow the established precedent.

And yes, I am aware that it will never happen.

Tim

---

From: Ole Jacobsen <[email-masked]>
Date: Tue, 21 Sep 2010 10:01:03 -0700 (PDT)

http://il.youtube.com/watch?v=Fk1f9uP42D0&feature=related

Ole J. Jacobsen
Editor and Publisher,  The Internet Protocol Journal
Cisco Systems
Tel: +1 408-527-8972   Mobile: +1 415-370-4628
E-mail: [email-masked]  URL: http://www.cisco.com/ipj

---

From: Dave Cridland <[email-masked]>
Date: Tue, 21 Sep 2010 18:44:21 +0100

> http://il.youtube.com/watch?v=Fk1f9uP42D0&feature=related

So trolling is a specific form of fisking. Makes sense.

Dave.

---

From: Martin Rex <[email-masked]>
Date: Tue, 21 Sep 2010 19:54:28 +0200 (MEST)

> sometimes large delays (moderated lists?) that (at least) [email-masked] uses.

Stripping quoted text to the relevant would be a HUGE improvement.

Some Mails arrive with quotations that are extremely hard to read,
due to lack of visual clue, like vertical whitespace and indentation
with quotation character.

> original comment 1
> [zz] comment 1zz
> original comment 2
> original comment 3
> original comment 4
> [zz] comment 4zz
[yy] comment 4yy
> original comment 5
> original sig
> [zz] 2nd sig

When the ratio new/quoted is small, then (a) stripping to the relevant
is often inadequate or hasn't been done and (b) explicit top or bottom
posting is preferable.

Suggestion to [zz]:
  - change your quoting style (quoting char, vertical whitespace)
  - did you really need to quote "original comment 2", "original comment 3"
    and "original sig"?

Suggestion to [yy]:
  - change your quoting style (quoting char, vertical whitespace)
  - did you really need to quote anything besides "[zz] comment 4zz" ?

-Martin

---

From: "J.D. Falk" <[email-masked]>
Date: Tue, 21 Sep 2010 14:40:30 -0700

> In all seriousness, forcing any particular approach is the real issue.  I can't imagine how it would be accomplished.  What I'd really like to force people to do is be more thoughtful and restraine…

Perhaps encourage more proposals and counter-proposals to be in the form of I-Ds?

A handful of folks are trying that in the DKIM WG, and I think it may be helping.

---

From: Jari Arkko <[email-masked]>
Date: Wed, 22 Sep 2010 06:26:16 -0700

Dave,

The
primary argument in favour of inline responses is that they allow
context to be retained.

Yes. Context is essential to understanding why a comment is being made.
For instance, the poster may support or disagree with a particular
assertion expressed earlier in the discussion.

However, sometimes I see posters on some lists fall back on a simpler
form of retaining context, where the unabridged discussion history gets
quoted on all new messages. I don't know if we slip into this mode out
of convenience or because we somehow assume that the other readers (and
their mail tools) on the list are stateless and have no memory of past
events. The stateless assumption may well be true in some cases though
:-)

I would suggest that being liberal in searching for context and
conservative in providing it would be a better model...

Jari (your resident top-poster. in html. yuck)

---

From: Keith Moore <[email-masked]>
Date: Wed, 22 Sep 2010 11:57:45 -0400

On Sep 22, 2010, at 9:26 AM, Jari Arkko wrote:

> Dave,
> 
>> The primary argument in favour of inline responses is that they allow context to be retained.
> 
> Yes. Context is essential to understanding why a comment is being made. For instance, the poster may support or disagree with a particular assertion expressed earlier in the discussion.
> 
> However, sometimes I see posters on some lists fall back on a simpler form of retaining context, where the unabridged discussion history gets quoted on all new messages. I don't know if we slip into this mode out of convenience or because we somehow assume that the other readers (and their mail tools) on the list are stateless and have no memory of past events. 

My theory is that email user agents have somehow, overall, become less functional over time in allowing people to quote portions of previous messages and insert new text into such quoted messages.  I think this actually got worse when it became conventional to compose messages (and quote replies) in HTML.

Keith

---

From: Dave Cridland <[email-masked]>
Date: Wed, 22 Sep 2010 18:21:39 +0100

On Wed Sep 22 16:57:45 2010, Keith Moore wrote:
> > However, sometimes I see posters on some lists fall back on a  
> simpler form of retaining context, where the unabridged discussion  
> history gets quoted on all new messages. I don't know if we slip  
> into this mode out of convenience or because we somehow assume that  
> the other readers (and their mail tools) on the list are stateless  
> and have no memory of past events.
> 
> My theory is that email user agents have somehow, overall, become  
> less functional over time in allowing people to quote portions of  
> previous messages and insert new text into such quoted messages.  I  
> think this actually got worse when it became conventional to  
> compose messages (and quote replies) in HTML.

Possibly. It's worth noting that format-flowed, for instance, is well  
supported and very good at quoting unambiguously, whilst retaining  
the flowed text that's a primary driver for HTML email.

Dave.

---

From: "t.petch" <[email-masked]>
Date: Wed, 22 Sep 2010 18:35:38 +0200

----- Original Message -----
From: "Martin Rex" <[email-masked]>
To: "Randy Dunlap" <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, September 21, 2010 7:54 PM
>   - did you really need to quote "original comment 2", "original comment 3"

Martin

Would that I could change my quoting style.  My MUA, supplied by the
organisation that supplies most of the world's MUAs, will put in a greater than
sign as a quoting char provided you sent me 7bit .

But should you use quoted-printable, then there is no quoting character and I am
reduced to inserting XML style tags.

Mutter, mutter, mutter

Tom Petch

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Tue, 21 Sep 2010 13:00:47 -0400

I read the post that I was replying to.

Given that the poster was claiming Rod Beckstrom as the inspiration for the
Tea Party, I did not consider the actual contents of the book very relevant
since the fallacies in the original post are that the Tea Party is a
decentralized movement and that its organization is somehow novel.

It is a matter of record that the major tea party events reported in the
mainstream media were organized by Fox News and 'Freedom Works'.

On Tue, Sep 21, 2010 at 10:48 AM, Jorge Amodio <[email-masked]> wrote:

> > I'll admit it...I was really disappointed to learn how Phillip had
> defined that word.  I think the word should be reserved for something
> naughtier.
> >
> > And yes, top posting really is inherently evil. :)  There's no need to
> quote an entire (long) message for context, that's what the In-Reply-To
> field is for.
> >
> >

---

From: Tony Finch <[email-masked]>
Date: Wed, 22 Sep 2010 19:48:08 +0100

On Wed, 22 Sep 2010, Dave Cridland wrote:
> supported

... with the notable exception of Outlook. Apple's MUAs have stopped using
format=flowed and now use really long lines instead, because that give
better interop with the market leader. This is rather sad.

Tony.
-- 
f.anthony.n.finch  <[email-masked]>  http://dotat.at/
HUMBER THAMES DOVER WIGHT PORTLAND: NORTH BACKING WEST OR NORTHWEST, 5 TO 7,
DECREASING 4 OR 5, OCCASIONALLY 6 LATER IN HUMBER AND THAMES. MODERATE OR
ROUGH. RAIN THEN FAIR. GOOD.

---

From: Keith Moore <[email-masked]>
Date: Wed, 22 Sep 2010 15:36:04 -0400

> reduced to inserting XML style tags.

The really sad thing is that MIME has been in existence for 15 years with essentially no changes, and people still haven't figured out that the way an object is interpreted and presented should be completely independent of the content-transfer-encoding.

When will people learn?

Keith

---

From: George Michaelson <[email-masked]>
Date: Thu, 23 Sep 2010 09:07:34 +1000

UI like the iPhone make top-post for short responses almost unavoidably easier.

"7 vital signs of a with-it manager from mars or venus (your choice)" books very probably also recommend it, I notice that people who move from strict technical roles into managerial ones are very prone to doing a +1 or "I agree" or "go ahead" as a top post with the entire thread retained.

the same people also complain when I trim.

So its a combination of pathological behaviours, UI, and dominance behaviour

-G

---

From: Randy Dunlap <[email-masked]>
Date: Thu, 23 Sep 2010 10:43:11 -0700

> "7 vital signs of a with-it manager from mars or venus (your choice)" books very probably also recommend it, I notice that people who move from strict technical roles into managerial ones are very…

Of course, anything to help their busy lives. (with <sarcasm>)

> So its a combination of pathological behaviours, UI, and dominance behaviour

That should just be a function of where the UI software positions the cursor,
shouldn't it?

---
~Randy

---

From: David Morris <[email-masked]>
Date: Thu, 23 Sep 2010 11:25:20 -0700 (PDT)

> So its a combination of pathological behaviours, UI, and dominance behaviour

Or perhaps they find the ability to quickly regain context useful give the
continuous variety of topics they handle ... or perhaps they feel that
trimming is quoting out of context and they prefer to control any bias
to what they receive.

---

From: Jari Arkko <[email-masked]>
Date: Thu, 23 Sep 2010 16:21:17 -0700

I agree

---

From: Keith Moore <[email-masked]>
Date: Thu, 23 Sep 2010 19:35:31 -0400

> So its a combination of pathological behaviours, UI, and dominance behaviour

+1

---

From: Sabahattin Gucukoglu <[email-masked]>
Date: Fri, 24 Sep 2010 07:40:27 +0100

On 22 Sep 2010, at 19:48, Tony Finch wrote:
> .... with the notable exception of Outlook. Apple's MUAs have stopped using

It is very sad.  So I wasn't mistaken - Apple Mail used to do the right thing, and now no longer does. Please file bug reports at http://bugreporter.apple.com/ .  With enough "Duplicates" it's possible Apple will listen to reason, but ...  Meantime I'll have to post to netnews using a newsreader in order to avoid being flamed to death by users of readers which decode the QP-encoding but then don't wrap the long lines, or don't do MIME.

Just out of curiosity, where did you get confirmation that Apple Mail behaves the way it does for the reason it does?

Cheers,
Sabahattin

---

From: Tony Finch <[email-masked]>
Date: Fri, 24 Sep 2010 11:51:21 +0100

On Fri, 24 Sep 2010, Sabahattin Gucukoglu wrote:
>
> Just out of curiosity, where did you get confirmation that Apple Mail
> behaves the way it does for the reason it does?

Can't remember, sorry.

Tony.

---

From: John C Klensin <[email-masked]>
Date: Fri, 24 Sep 2010 09:09:08 -0400

--On Thursday, September 23, 2010 10:43 -0700 Randy Dunlap
<[email-masked]> wrote:

>...
> That should just be a function of where the UI software
> positions the cursor, shouldn't it?

Well, it is a bit more than that.  If one had a UI that combines:

	-- Small screen with tricky selection and scrolling
	
	-- Insertion of prior messages in the reply with a
	"---original message--" line above them, rather than
	quoting.  Note that, when this is done, the cursor
	inevitably ends up above the message.
	
	-- No mechanism for selecting which text is to be quoted
	as part of the "reply" command (or button, or whatever)

or even any two of those, then one is quite likely to see
top-posting -- almost anything else is just too time-consuming.

In a better world, the "right" solution to that type of problem
is certainly "go find a decent MUA".  But, in a world in which
the number of MUAs that are well-designed and competently
maintained to keep up with technology developments appears to be
rapidly declining, the decision to switch tends to involve
complex usability and feature tradeoffs, not a straightforward
decision to go to something better.

In (slight) defense of top-posting (which I definitely choose to
do sometimes), if one is replying very briefly and in summary to
a long and complex message, it is often more efficient for both
the writer and the reader.  One should clearly also trim the
long message, but, if people get in a hurry and forget ... well,
I would hope that we will never again see a time in which the
bandwidth or disk space requirements for a few extra paragraphs
are sufficiently expensive to be more important than people's
time.

FWIW, the thing that really irritates me is having someone
respond to a message after quoting only a few lines (often good)
but without supplying some clue that permits me to find the
message being replied to if needed.  Whether that is done by
inserting some sort of attribution line, copying the author of
the prior message on the reply, or even using a good In-reply-to
field, assuming that one can quote a few lines, without
attribution, because the recipient has "obviously" read the
prior sequence of messages --in sequence and recently-- is just
unrealistic, at least IMO.  Again, the causes of the problem of
replies without prior message context are often more poor UA
design than bad user behavior, but that brings us back to the
declining population of decent UAs.

    john

---

From: Randy Dunlap <[email-masked]>
Date: Fri, 24 Sep 2010 08:17:18 -0700

> 	inevitably ends up above the message.

I don't think that the cursor has to end up there.  That's the MUA
and it could control where the cursor ends up.

> top-posting -- almost anything else is just too time-consuming.
[snip]
> long message, but, if people get in a hurry and forget ... well,

Forget?  oh, you are just being too nice.  ;)

> are sufficiently expensive to be more important than people's

Yes, I agree, it's about people's time.

> FWIW, the thing that really irritates me is having someone

Ack that.

One thing that bothers me is when people do mixed-line posting
but end their reply say, < 50% thru the message, but then they
don't delete the rest of the message, so the reader has to scan
the rest of the message to see if there are more comments.

This saves time for the (one) sender and wastes time for N readers.

---
~Randy

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 24 Sep 2010 11:36:57 -0400

I tend to assume that people write emails the way they would like to 
read them.

Thus, if I am writing an email with a lot of detailed context from a 
previous message, I include the revelant portions of the message, and 
reply in line.

However, when I am writing A reply that does not require detailed 
context, but may depend upon some context for either those who have not 
been reading everything, or the cases where the thread is complex enough 
that checking which piece one is responding to (even when the subject 
should not have changed) can be helpful,
then I top post.

Why do I top-post?
Because I prefer to read email in the preview pane of my email reader. 
It is much faster for me to read.  Top-posts I can generally read in the 
preview pane with 0 additional clicks.  I can go scroll down and read 
the selected context if I need that.
In contrast, with a bottom post I have to scroll through the whole 
thread, most of which I have read before, just to find out what this 
poster is adding.

Since, as a reader, I strongly prefer to read top-posts, that is how I 
usually post.

In this case, it is pretty clear that the details of the earlier 
conversation are relevant only to prove that a conversation is taking 
place, so I will assume readers who care have read those posts, and I 
have deleted it all.

It is very true that if you are trying to parse a thread that you have 
not been following, a thread where everyone has bottom posted, while 
retaining sufficient context, is MUCH easier to figure out.  I have had 
more than one thread where I have had to read the top-posts backwards 
from the bottom to figure out what the heck is going on.
But that, for me, is a rare case.

Other people probably read differently.  So I do not claim that my 
reading experience is relevant for how other people shoudl post.  I will 
cope however things are posted.

I do want to re-iterate two points I have seen that are important.  Both 
are relevant no matter what style of posting you like.
1) People need to read the whole email before composing their response. 
  (You can draft ideas while reading, but make sure you actually read 
the whole thing before you finalise your response.)
2) People need to edit longer threads so that they do not copy large 
amounts of redundant and useless text.

I will note on 1 that the satiric demonstration of this that followed 
shortly after the initial note was just beautiful.  Thank you.

Yours,
Joel M. Halpern

---

From: Marshall Eubanks <[email-masked]>
Date: Fri, 24 Sep 2010 12:11:36 -0400

On Sep 24, 2010, at 11:36 AM, Joel M. Halpern wrote:

> I tend to assume that people write emails the way they would like to read them.
> 
> Thus, if I am writing an email with a lot of detailed context from a previous message, I include the revelant portions of the message, and reply in line.
> 
> However, when I am writing A reply that does not require detailed context, but may depend upon some context for either those who have not been reading everything, or the cases where the thread is complex enough that checking which piece one is responding to (even when the subject should not have changed) can be helpful,
> then I top post.
> 
> Why do I top-post?
> Because I prefer to read email in the preview pane of my email reader. It is much faster for me to read.  Top-posts I can generally read in the preview pane with 0 additional clicks.  I can go scroll down and read the selected context if I need that.
> In contrast, with a bottom post I have to scroll through the whole thread, most of which I have read before, just to find out what this poster is adding.
> 
> Since, as a reader, I strongly prefer to read top-posts, that is how I usually post.
> 

I don't much care, but in general I think that a simple "WFM" or the like should be top posted; otherwise go with what seems the most natural to read. 

Regards
Marshall

> In this case, it is pretty clear that the details of the earlier conversation are relevant only to prove that a conversation is taking place, so I will assume readers who care have read those posts, and I have deleted it all.
> 
> It is very true that if you are trying to parse a thread that you have not been following, a thread where everyone has bottom posted, while retaining sufficient context, is MUCH easier to figure out.  I have had more than one thread where I have had to read the top-posts backwards from the bottom to figure out what the heck is going on.
> Other people probably read differently.  So I do not claim that my reading experience is relevant for how other people shoudl post.  I will cope however things are posted.
> 
> I do want to re-iterate two points I have seen that are important.  Both are relevant no matter what style of posting you like.
> 1) People need to read the whole email before composing their response.  (You can draft ideas while reading, but make sure you actually read the whole thing before you finalise your response.)
> 2) People need to edit longer threads so that they do not copy large amounts of redundant and useless text.
> 
> I will note on 1 that the satiric demonstration of this that followed shortly after the initial note was just beautiful.  Thank you.
> 
> Yours,
> Joel M. Halpern
>

---

From: Tony Finch <[email-masked]>
Date: Fri, 24 Sep 2010 19:21:03 +0100

On Fri, 24 Sep 2010, John C Klensin wrote:
>
> FWIW, the thing that really irritates me is having someone respond to a
> message after quoting only a few lines (often good) but without
> supplying some clue that permits me to find the message being replied to
> if needed.  [...] or even using a good In-reply-to field, [...]

Another example of Outlook's bad interoperability. I believe that there
was one release in which it implemented standard message threading, but
some bright spark decided to reinvent the wheel badly.

Tony.

---

From: John C Klensin <[email-masked]>
Date: Fri, 24 Sep 2010 21:21:16 -0400

> This saves time for the (one) sender and wastes time for N

Again, if we all had consistent habits, many of these things
would be non-problems.  But we don't, and I don't know how to
fix that.

For that case in particular, I've sometimes done it
deliberately, but...

-- I always close/"sign" actual messages by typing my name, not
relying on some signature block.  So, if you see "john" or
"--john", not immediately following by a "p.s." or something
else with a forward pointer from the text above, I'm finished.

-- Given that, I sometimes leave additional text as context for
those who might need it, expecting that others will understand
that they don't need to read anything after the signature line.
Your comment suggests that expectation has been unreasonable.

    john

---

From: Michael Richardson <[email-masked]>
Date: Fri, 24 Sep 2010 21:53:53 -0400

>>>>> "Tony" == Tony Finch <[email-masked]> writes:
    Tony> On Fri, 24 Sep 2010, John C Klensin wrote:
    >> message being replied to if needed.  [...] or even using a good
    >> In-reply-to field, [...]

    Tony> Another example of Outlook's bad interoperability. I believe
    Tony> that there was one release in which it implemented standard
    Tony> message threading, but some bright spark decided to reinvent
    Tony> the wheel badly.

Yes. And now we have 15 years of this bad behaviour.

My new financial planner had actually NEVER seen someone not top-quote, and
he actually thought his computer was broken, and couldn't figure out how
my text had moved.  I do not think he realizes that you can even edit
the quoted text.  He is less than 30, so literally, he has never used
anything else.

I've also been told that some organizations retain everything as audit.
(If they really wanted that, they should use message/rfc822, with an
embedded signature)    

Such a nice social engineering hack on them to start CC'ing someone with
a made up "history" of some dispute, and claim it is true, alas, I've
never found a sufficiently interesting situation to bother trying it
out.

-- 
]       He who is tired of Weird Al is tired of life!           |  firewalls  [
]   Michael Richardson, Sandelman Software Works, Ottawa, ON    |net architect[
] [email-masked] http://www.sandelman.ottawa.on.ca/ |device driver[
   Kyoto Plus: watch the video <http://www.youtube.com/watch?v=kzx1ycLXQSE>
	               then sign the petition.

---

From: Olaf Kolkman <[email-masked]>
Date: Mon, 27 Sep 2010 10:21:41 +0200

> 2) People need to edit longer threads so that they do not copy large amounts of redundant and useless text.

I would think that there is a 3rd point: 
3) Think about what you would want to communicate, who to communicate to, and what style fits best. Fisking, classical Oxbridge rhetoric, top-posting, satire, acronyms (WFM, or 1+), one-liners, essays, YELLING, not-replying-at-all, &c, &c all seem to have their own effectivity and charm.

In that contest I observe that by looking at the  "From: " header you can often predict the style that is used while in an ideal world you would like to see correlation with the "Subject: " header.

--Olaf

[*] See for the whole thread: https://www.ietf.org/ibin/c5i?mid=6&rid=49&gid=0&k1=933&k2=53746&tid=1285574931

---

From: "Richard L. Barnes" <[email-masked]>
Date: Mon, 27 Sep 2010 10:37:56 -0400

NEW NON-IETF LIST ANNOUNCEMENT

IETF Meta-Discussions

This group is dedicated to the discussion of ancillary issues of  
interest to the IETF community, especially discussions about how IETF  
discussions and meetings should work.
-- IETF meeting locations / travel 
-- Email composition design patterns 
-- Anything related to DiffServ politics

<http://groups.google.com/group/ietf-meta>

On Sep 20, 2010, at 2:20 PM, Phillip Hallam-Baker wrote:

> Are you crazy, the last three vans were yellow. Only an idiot would  
> buy a red van (etc)
>
> > Because even though yellow is traditional the red one is on sale  
> for $1000 off.
>
> where it is very clear to me that the poster did not bother to read  
> the entire message before starting their reply. In particular I have  
> read rather a lot of people starting off by accusing their opponent  
> of being ignorant of issues that their opponent actually states only  
> a few paragraphs further on.
>
>
> Traditionally, top-posting (or bottom posting) has been discouraged  
> in favor of responding line by line. I think it is time to reverse  
> that preference.
>
> somewhat shorter in mediums where people are forced to restate the  
> issue they are objecting to in their own words.
>
> --

---

From: Dave Cridland <[email-masked]>
Date: Mon, 27 Sep 2010 15:46:35 +0100

On Mon Sep 27 15:37:56 2010, Richard L. Barnes wrote:
> interest to the IETF community, especially discussions about how  
> IETF  discussions and meetings should work.

Oh, I thought it was the technical rubbish that was off-topic here.

Dave.