Subject: RE: Optimizing for what? Was Re: IETF Attendance by continent

From: "Glen Zorn" <[email-masked]>
Date: Wed, 1 Sep 2010 14:36:47 +0700

Clint Chaplin [mailto:[email-masked]] writes:

> On Tue, Aug 31, 2010 at 9:15 PM, Randall Gellens <[email-masked]>
> wrote:
> > At 10:08 AM +0700 9/1/10, Glen Zorn wrote:
> >
> >>  > > Why Kauai?  You list detailed reasons why Hawaii is logical and
> >>>
> >>>  > solves for many of the problems, but you don't say why this
> island.
> >>>
> >>>  Because it's the nicest, obviously. :)
> >>
> >>  I strongly disagree: the leeward coast of Maui (in particular, Kihei
> &
> >>  south) is far better.  Kauai is way too rainy...
> >
> > However, any of the Hawaiian
> > islands would be a great choice, given the ease of travel
> arrangements, the
> > warm weather which reduces the need for much of the luggage (no need
> for
> > warm clothes),
> 
> IEEE 802 wireless interim meetings in September have been at the
> Waikoloa Resort for the last few years.  The meeting rooms are so
> heavily air condituoned that the attendees now know to bring a sweater
> to the meeting.

Bad luck/poor communication?  The meetings I've attended there (both IEEE &
WiMAX) have been comfortable

> 
> 
> >
> > --
> > Randall Gellens
> > Opinions are personal;    facts are suspect;    I speak for myself
> only
> > -------------- Randomly selected tag: ---------------
> > Anything labeled "NEW" and/or "IMPROVED" isn't.  The label means the
> > price went up.  The label "ALL NEW", "COMPLETELY NEW", or "GREAT NEW"
> > means the price went way up.
> > _______________________________________________
> > Ietf mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/ietf
> >
> 
> 
> 
> --
> Clint (JOATMON) Chaplin
> Principal Engineer
> Corporate Standardization (US)
> SISA

---

From: Tobias Gondrom <[email-masked]>
Date: Wed, 01 Sep 2010 10:05:53 +0100

On 09/01/2010 07:35 AM, Yoav Nir wrote:
> On Aug 31, 2010, at 4:56 PM, Iljitsch van Beijnum wrote:
>
>>> Consider that contributors
>>> usually start as newcomers, attend several meetings, then write a draft,
>> I don't know about you, but I wrote drafts before my first meeting.
> Me too. I actually had an RFC published two months before attending my first meeting.
>
> As an employee (rather than an independent consultant) if I ask my bosses to go to an IETF meeting, their first question is what am I going to do there.  A good answer is that I want to present this draft in that working group, participate in this discussion at another working group, and meet this person to talk about that subject.
>
> If I just said I want to go to some meetings, and listen to stuff, and see if I hear anything interesting, they'd tell me to use the audio stream for that.
>
> OTOH we've all seen a whole bunch of people at meetings who always sit in the back, faces buried in their laptops, and never participating in any discussion.  I'm not sure what value their employer gets from their participation, but I guess both models exist.
You are right, I did so too (and presented my first draft at the first
meeting). However, I would say it was a bit exciting and the quality of
my I-D improved drastically after the meeting and receiving direct
(face-to-face) feedback and advise from a number of people at the
meeting. If I wouldn't have gone there, it might also have been my last
I-D. And there is a lot going on beyond the meeting itself (or its audio
stream which we didn't have back then when I started), e.g. the informal
follow-up conversations with others after the meeting triggered by their
questions and comments and feedback from the WG chair or AD on a draft
and how to progress after the meeting can be equally valuable as the
meeting itself.

However, this way ("write I-D and attend the first time") is not the
only one: looking at participation numbers, there is a portion of people
(btw. relatively independent of meeting location) attending for the
first time who probably want to understand the waters first before
plunging in with a draft or who are involved and provide valuable input
to drafts without beeing the author or even without speaking up during
the meeting (e.g. prefer to communicate later via email). And I actually
saw some present at a later meeting themselves. (Although I only deduct
this motivation only based on my personal anecdotal evidence, number of
talks I had on the floor over couple of years and no hard statistics).

And just to be complete: Of course there is also a portion of people who
come only for "look and see" (and some of them may actually be
implementers and help you bring a draft to wider adoption) - however
it's hard to tell them apart from the ones who "look and learn to
contribute later". I value both groups very much as well and probably
some of them don't even know themselves which group they are until
they've been to a meeting and find out that writing a draft is not that
mystically difficult.

Best regards, Tobias

---

From: Marshall Eubanks <[email-masked]>
Date: Wed, 1 Sep 2010 10:56:13 -0400

On Aug 28, 2010, at 1:25 PM, Scott Brim wrote:

> On 08/28/2010 12:28 EDT, Adrian Farrel wrote:
>> And even closer to 3:2:2 ?

I think that people have unreasonable expectations about what we can do here.

There are 3 meetings per year, and 3 meeting regions being considered, and we are generally considering something between 1 and 3 years out at any time. 

Suppose that the time horizon is 2 years. Then, an equal meeting schedule is 

2:2:2 (which is equivalent to 1:1:1, of course).

If we shift one meeting, we have

3:2:1  (the current proposal) - or 1:0.66:0.33

If we shift 2 meetings, we have 

4:1:1  - or 1:0.25:0.25

and that's it. Without having no meetings in some region, 1:1:1, 3:2:1, or 4:1:1 is all we can chose between with a 2 year horizon. 

(You have to chunk the meetings somehow to get these ratios; doing by calendar years is a very reasonable chunk that fits well with the way that meetings are scheduled.)

Suppose that our time horizon is 3 years - then an equal meeting schedule is

3:3:3 and we can shift meetings to produce

4:3:2 - or 1:0.75:0.5
4:4:1 - or 1:1:0.25
5:2:2 - or 1:0.4:0.4
5:3:1 - or 1:0.6:0.2
6:2:1 - or 1:0.33:0.16
7:1:1 - or 1:0.14:0.14

and that's it (without dropping some region entirely). 

So, for example, instead of 3:2:2 (or 1:0.66:0.66) I would recommend 4:3:2 for the next 3 years
(the closest triplet using an absolute value sum metric on the differences). 4:3:2 would be easier to do than 3:2:2 based on the way we schedule and review meeting locations.

Now, of course, meeting locations do get moved, and 4:3:2 might easily turn into 4:4:1 or 3:3:3 based on contingencies. 

I do not think it is reasonable to apply a time horizon of > 3 years to IETF meeting locations. Attendance is changing too rapidly for that.

Regards
Marshall 

> +0.2

---

From: Ross Callon <[email-masked]>
Date: Wed, 1 Sep 2010 11:24:31 -0400

Why does this have to be precisely on an integer-number year boundary? 

Ross

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Marshall Eubanks
Sent: Wednesday, September 01, 2010 10:56 AM
To: Scott Brim
Cc: Adrian Farrel; [email-masked]
Subject: Re: IETF Attendance by continent

4:1:1  - or 1:0.25:0.25

4:3:2 - or 1:0.75:0.5
4:4:1 - or 1:1:0.25
5:2:2 - or 1:0.4:0.4
5:3:1 - or 1:0.6:0.2
6:2:1 - or 1:0.33:0.16
7:1:1 - or 1:0.14:0.14

Regards
Marshall

---

From: Marshall Eubanks <[email-masked]>
Date: Wed, 1 Sep 2010 12:24:27 -0400

> Why does this have to be precisely on an integer-number year boundary? 

It doesn't have to be. It could, in principle, be anything that the community wants. 

My real point here, which I may not have gotten across, is that meeting scheduling is a fairly blunt tool. The community cannot expect too much precision in this. At any time there are meetings at various degrees of being scheduled some years out, meetings have had to be rescheduled (i.e., prospective venues have fallen through) in the past and likely will again in the future, and external events also sometimes constrain when we can meet where. If the desired X:Y:Z goal is not being obtained all the IAOC can do is to change or swap meeting locations, and there are generally strong constraints on that (i.e., some meetings may be firmly scheduled some time out,  there may be cancelation penalties on some Hotel contracts, certain sponsors may insist on "their" meeting being in a certain location at a certain time, etc.). Then the IAOC is open to complaints such as "there are 2 meetings in Region X back to back", or "there are no meetings in Region Y at all this year."

So, I would recommend simple goals with short repeat cycles, such as 3:2:1 or 1:1:1, and also repeat cycles that commensurate with a integer number of years (where that integer is 1, 2 or 3).  I don't think the system is likely to deliver more fine grained performance than that.

Regards
Marshall

---

From: Stephan Wenger <[email-masked]>
Date: Wed, 01 Sep 2010 10:20:59 -0700

It can, of course.  Use D'Hondt or something to pick the next meeting venue.
Stephan

On 9.1.2010 08:24 , "Ross Callon" <[email-masked]> wrote:

> There are 3 meetings per year, and 3 meeting regions being considered, and we
> are generally considering something between 1 and 3 years out at any time.
> 
> and that's it. Without having no meetings in some region, 1:1:1, 3:2:1, or
> 4:1:1 is all we can chose between with a 2 year horizon.
> 
> (You have to chunk the meetings somehow to get these ratios; doing by calendar
> years is a very reasonable chunk that fits well with the way that meetings are
> scheduled.)
> 
> (the closest triplet using an absolute value sum metric on the differences).
> 4:3:2 would be easier to do than 3:2:2 based on the way we schedule and review
> meeting locations.
> 
> Now, of course, meeting locations do get moved, and 4:3:2 might easily turn
> into 4:4:1 or 3:3:3 based on contingencies.
> 
> I do not think it is reasonable to apply a time horizon of > 3 years to IETF
> meeting locations. Attendance is changing too rapidly for that.
> 
> Regards
> Marshall 
> 
>> 
>> +0.2

---

From: Joel Jaeggli <[email-masked]>
Date: Wed, 01 Sep 2010 11:05:36 -0700

> Why does this have to be precisely on an integer-number year boundary? 

There are several methods one could use. propose one.

meetings 80 81 82 85 and 86 already have locations so I'm guessing the
experiment starts in earnest in august 2013.

---

From: Doug Barton <[email-masked]>
Date: Wed, 01 Sep 2010 11:19:43 -0700

Marshall,

While I admire your math skills I think you're making this way more 
complicated than it needs to be. (In the IETF? Perish the thought!)

1. Figure out what the desired ratio is
2. Add up the total number of meetings represented by the ratio
3. Multiply by 2 to arrive at number N
4. Starting with the first available open meeting date, plan the next N 
meetings as close as possible to the desired ratio.
5. At the half-way point between now and the end of N; lather, rinse, 
repeat.

hth,

Doug

---

From: Jari Arkko <[email-masked]>
Date: Thu, 02 Sep 2010 09:07:24 +1200

I think we are over-analyzing this. Do not be too focused on the 
numbers, or whether current <pick your metric> points to 1, 1.7, or 2. I 
think it is more important to think about where the IETF is headed and 
where Internet and networking work seems to be happening in the world. 
 From that perspective I would personally prefer to see 1:1:1, and in 
any case, venue/contract/sponsor/planninghorizon/unforeseenevent 
probably cause more fluctuation than what our possible more fine-grained 
policy would give.

In other words, "close enough" and let the IAOC worry about the details.

Jari

---

From: Michael StJohns <[email-masked]>
Date: Wed, 01 Sep 2010 18:36:14 -0400

Hi Marshall - 

A method that works for any ratio using running totals:

Let NAp, Ep, Ap be the value of each regions part of the ratio (e.g. NAp = 1.7 for a 1.7:1:1)

Set NAt(0), Et(0), At(0) = 0

Set NAs= NAp/(NAp+Ep + Ap)  (basically the decimal version of the ratio), repeat for Es and As

For each meeting 'i' let NAt(i) = NAt(i-1) +NAs - (if meeting in NA ? 1 : 0)
and repeat the same for each region.  [Basically add the meeting credit XXs (NAs, Es, As) to the running credit total and subtract one from the credit if the meeting is held in the region]

XXt(i) gives you the number of meetings "owed" to that region - or if negative, the surplus.

This is easiest to see if you map it out on a spread sheet.  

A simple model is to attempt first to plan a meeting in the region with the greatest arrears falling back to the next greatest etc.

Any luck in deriving the other data I asked about?  E.g. looking only at the Nomcom qualified and the "contributors"?

Thanks - Mike

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 2 Sep 2010 07:40:57 +0200

Hi,

I agree with Jari.

In my opinion, the discussion whether we should change the meeting calendar (not having meetings during summer vacation months etc) was much more interesting and useful.

Regards,

Christer

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Jari Arkko
> Sent: 2. syyskuuta 2010 0:07
> To: [email-masked]
> I think we are over-analyzing this. Do not be too focused on 
> the numbers, or whether current <pick your metric> points to 
> 1, 1.7, or 2. I think it is more important to think about 
> where the IETF is headed and where Internet and networking 
> work seems to be happening in the world. 
>  From that perspective I would personally prefer to see 
> 1:1:1, and in any case, 
> venue/contract/sponsor/planninghorizon/unforeseenevent
> probably cause more fluctuation than what our possible more 
> fine-grained policy would give.
>

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Thu, 2 Sep 2010 11:26:45 +0200

> In my opinion, the discussion whether we should change the meeting calendar (not having meetings during summer vacation months etc) was much more interesting and useful.

To revisit that: if we move up all the meetings by one month, we gain a number of advantages:

- We avoid the middle of the vacation season, especially in Europe. This is an advantage if we want to meet in places that also attract tourists, although it could also be a disadvantage under some circumstances. Transport and other services aren't in vacation mode.

- We can go further south for the summer meeting without overheating

- We can go further north for the autumn meeting without undercooling

A february meeting would be in the coldest part of winter, so that meeting would have to be in a place where winters aren't too harsh. But then, march in Minneapolis is no picnic either.

---

From: Fernando Gont <[email-masked]>
Date: Thu, 02 Sep 2010 06:39:38 -0300

Iljitsch van Beijnum wrote:

> A february meeting would be in the coldest part of winter, so that
> meeting would have to be in a place where winters aren't too harsh.
> But then, march in Minneapolis is no picnic either. 

Even better: In the southern hemisphere, February and March is Summer
time. ;-)

Thanks,
-- 
Fernando Gont
e-mail: [email-masked] || [email-masked]
PGP Fingerprint: 7809 84F5 322E 45C7 F1C9 3945 96EE A9EF D076 FFF1

---

From: Dave CROCKER <[email-masked]>
Date: Wed, 01 Sep 2010 14:50:35 -0700

On 9/1/2010 2:07 PM, Jari Arkko wrote:
> I think it is more important to think about where the IETF is headed and where
> Internet and networking work seems to be happening in the world. From that
> perspective I would personally prefer to see 1:1:1

+1

And I think the statistics do show that trend rather clearly.

d/
-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: "Andrew G. Malis" <[email-masked]>
Date: Sun, 5 Sep 2010 18:39:14 -0400

I've been to several conferences at the Hilton Hawaiian Village in
Waikiki. Both the hotel and the attached convention center are large
enough to host several IETFs simultaneously.

Cheers,
Andy

On Tue, Aug 31, 2010 at 11:08 PM, Glen Zorn <[email-masked]> wrote:
> Hadriel Kaplan [mailto://[email-masked]] writes:
>
> ...
>
>> >
>> > Why Kauai?  You list detailed reasons why Hawaii is logical and
>> > solves for many of the problems, but you don't say why this island.
>>
> I strongly disagree: the leeward coast of Maui (in particular, Kihei &
>> >>   We can even rotate islands if people get bored.
>> >
>> > Well, there are extensive conference facilities on Oahu, the Big
>> > Island, Maui, and Kauai.  I have no information as to if they would
>> > work for a group of our size and with our need for breakout rooms.
>>
>> I used to attend IEEE 802 and they met in Kauai (Grand Hyatt in Poipu)
>> every few years, but they were a smaller group.  There aren't many
>> restaurants nearby, but I certainly don't remember anyone ever
>> complaining about it. ;)
>
> 3GPP2 used to (still does?) meet in Wailea every December.  Although that is
> also a much smaller group than the IETF, the hotels dwarfed it so it might
> be possible to find a reasonable venue for the IETF.  However, I think that
> this is just an idle fantasy: the IETF has too much moral fiber to meet
> someplace that might actually be fun ;-).
>
>>
>> -hadriel

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 6 Sep 2010 07:16:43 +0200

Hi,

I assume Hawaii has the same visa issues as the rest of US...

Regards,

Christer

> Behalf Of Andrew G. Malis
> Sent: 6. syyskuuta 2010 1:39
> To: Glen Zorn
> Cc: Randall Gellens; IETF-Discussion list; Hadriel Kaplan
> Subject: Re: Optimizing for what? Was Re: IETF Attendance by continent
> 
> I've been to several conferences at the Hilton Hawaiian 
> Village in Waikiki. Both the hotel and the attached 
> convention center are large enough to host several IETFs 
> simultaneously.
> 
> Cheers,
> Andy
> 
> >> I used to attend IEEE 802 and they met in Kauai (Grand Hyatt in 
> >> Poipu) every few years, but they were a smaller group.  
There aren't 
> >> many restaurants nearby, but I certainly don't remember 
> anyone ever 
> >> complaining about it. ;)
> >
> > 3GPP2 used to (still does?) meet in Wailea every December.  
Although 
> > that is also a much smaller group than the IETF, the hotels 
> dwarfed it 
> > so it might be possible to find a reasonable venue for the IETF.  
> > However, I think that this is just an idle fantasy: the 
> IETF has too 
> > much moral fiber to meet someplace that might actually be fun ;-).
> >
> >>
> >> -hadriel

---

From: Yoav Nir <[email-masked]>
Date: Mon, 6 Sep 2010 10:06:23 +0300

True. 

But the visa issues seem to be the worst part of any US IETF. Travel, food and finding a hotel are typically much easier in most US venues then European venues. 

People from Europe, Japan, Australia, and some other countries don't need a visa at all to go to an IETF meeting in the US. People from China, India and the other countries are generally backed by employers, who can vouch for their travelling "on business", and generally should not have any trouble obtaining the US visa.

I would go so far as to say that getting a US visa seems easier than getting one to China. Who are the people for whom it's easier to visit a European country than it is to visit the US?

On balance, I think US venues are generally better suited, and lead to less angst than either European or Asian venues. Even if they're in a cold place like Minneapolis.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: 06 September 2010 08:17
To: Andrew G. Malis; Glen Zorn
Cc: Randall Gellens; IETF-Discussion list; Hadriel Kaplan
Subject: RE: Optimizing for what? Was Re: IETF Attendance by continent

Hi,

Regards,

Christer

---

From: "Glen Zorn" <[email-masked]>
Date: Mon, 6 Sep 2010 14:20:51 +0700

> I assume Hawaii has the same visa issues as the rest of US...

Of course, and the same heavily armed ICE agents.  As an aside, the only
other place I've ever encountered armed border guards was at the
Austrian/Slovakian border (before the fall of the Berlin Wall).

...

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 6 Sep 2010 09:41:48 +0200

ICE? So, that's the reason why it takes forever to enter US. They use RFC 5245 at the border...

Regards,

Christer 

> From: Glen Zorn [mailto:[email-masked]] 
> Sent: 6. syyskuuta 2010 10:21
> To: Christer Holmberg; 'Andrew G. Malis'
> Cc: 'Randall Gellens'; 'IETF-Discussion list'; 'Hadriel Kaplan'
> Of course, and the same heavily armed ICE agents.  As an 
> aside, the only other place I've ever encountered armed 
> border guards was at the Austrian/Slovakian border (before 
> the fall of the Berlin Wall).
> 
> ...
> 
>

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 6 Sep 2010 09:52:19 +0200

I guess the chinese (and other affected nationalities) can speak for themselves, but as far as I know it is not that easy to get a US visa - even with company backup etc. I have never heard about people having problems getting a chinese visa, but maybe such problems exist also.

Personally I don't care that much where the meetings take place - I am more interested WHEN they take place. For me it is the PEOPLE that make a meeting good or bad - not the location. There are people working in much worse conditions than we are, and still they manage to do a great job.

Regards,

Christer

> Behalf Of Yoav Nir
> Sent: 6. syyskuuta 2010 10:06
> To: IETF-Discussion list
> But the visa issues seem to be the worst part of any US IETF. 
> Travel, food and finding a hotel are typically much easier in 
> most US venues then European venues. 
> 
> People from Europe, Japan, Australia, and some other 
> countries don't need a visa at all to go to an IETF meeting 
> in the US. People from China, India and the other countries 
> are generally backed by employers, who can vouch for their 
> travelling "on business", and generally should not have any 
> trouble obtaining the US visa.
> 
> I would go so far as to say that getting a US visa seems 
> easier than getting one to China. Who are the people for whom 
> it's easier to visit a European country than it is to visit the US?
> 
> On balance, I think US venues are generally better suited, 
> and lead to less angst than either European or Asian venues. 
> Even if they're in a cold place like Minneapolis.
> 
> Behalf Of Christer Holmberg

---

From: "Glen Zorn" <[email-masked]>
Date: Mon, 6 Sep 2010 16:01:57 +0700

Yoav Nit [mailto://[email-masked]] writes:

...

> I would go so far as to say that getting a US visa seems easier than
> getting one to China. Who are the people for whom it's easier to visit a
> European country than it is to visit the US?

Umm, Americans?  I have lived outside the US for about three years now &
returning for a visit has always been painful, even if "normal".  The normal
pain includes answering such questions as "How long have you been gone?" and
"Why did you leave?" (??!), the natural response (which had better not be
given!) being "On what planet is that the business of the government?"; the
less normal pain (for most, I guess; it happened to me 14 times in a row
from 2000-2008, of course having nothing to do w/my political views ;-) is
being detained for a couple of hours while agents tear apart & inspect the
contents of my luggage, laptop, camera, mobile phone, etc.  By contrast, I
have visited at least two dozen other countries (many of them multiple
times) in Europe, Asia & North America over the last 25 years & had problems
w/Customs and/or Immigration exactly twice.

...

---

From: "Glen Zorn" <[email-masked]>
Date: Mon, 6 Sep 2010 16:08:33 +0700

Christer Holmberg [mailto://[email-masked]] writes:

> I guess the chinese (and other affected nationalities) can speak for
> themselves, but as far as I know it is not that easy to get a US visa -
> even with company backup etc. I have never heard about people having
> problems getting a chinese visa, but maybe such problems exist also.

If you hold a Thai passport & want to attend an IETF in, say, 2013, you had
better apply for a visa now; any meeting before that is likely impossible.

> 
> Personally I don't care that much where the meetings take place - I am
> more interested WHEN they take place. For me it is the PEOPLE that make
> a meeting good or bad - not the location. There are people working in
> much worse conditions than we are, and still they manage to do a great
> job.

Humans can do amazing things in truly abysmal conditions but how this is
relevant is beyond me unless the contest is to see how miserable we can make
ourselves (3 meetings/year in Minneapolis, anyone?).

...

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 6 Sep 2010 11:44:32 +0200

>>more interested WHEN they take place. For me it is the PEOPLE that 
>>make a meeting good or bad - not the location. There are people 
>>working in much worse conditions than we are, and still 
>>they manage to 
>>do a great job.
> 
>Humans can do amazing things in truly abysmal conditions but 
>how this is relevant is beyond me unless the contest is to 
>see how miserable we can make ourselves (3 meetings/year in 
>Minneapolis, anyone?).

The point is that we in IETF are a bunch of lazy and spoiled children.

I am not saying that we should see how miserable we can make ourselves on purpose. I am saying that if there is a will, there is a way.

Regards,

Christer

---

From: Xiangsong Cui <[email-masked]>
Date: Mon, 06 Sep 2010 17:53:58 +0800

> Sent: Monday, September 06, 2010 3:52 PM
> To: Yoav Nir; IETF-Discussion list
themselves,
> but as far as I know it is not that easy to get a US visa - even with
company

Yes, as far as I can tell, for Chinese, US visa is usually harder than
European visa :(

Xiangsong

---

From: Tim Bray <[email-masked]>
Date: Mon, 6 Sep 2010 03:27:50 -0700

I should point out that Canada has most of the logistical advantages the usa
enjoys, while imposing quite a bit less visa pain.
- Tim

---

From: "Glen Zorn" <[email-masked]>
Date: Mon, 6 Sep 2010 18:59:05 +0700

Tim Bray [mailto:[email-masked]] writes:

Well, yes, except that in my experience direct international flight to
Canada are a lot more expensive than international connections to Canada
through the US and since the concept of international transit is foreign to
the American authorities (after all, having reached Heaven on Earth why
would anyone want to go anywhere else? ;-), we're right back where we
started. 

.

---

From: Fernando Gont <[email-masked]>
Date: Mon, 06 Sep 2010 17:43:41 -0300

Tim Bray wrote:

> I should point out that Canada has most of the logistical advantages the
> usa enjoys, while imposing quite a bit less visa pain.

Actually, based on my own experience, getting a Canadian visa is usually
*faster* than getting a US visa, but probably much more *painful*.

That's my experience with getting Canadian visas (I have got four or
five), from Buenos Aires (Argentina), being an Argentinian citizen.

Europe is much better in this respect. For instance, they don't require
visas for many latin-american countries (including Argentina).

Thanks,

---

From: Jelte Jansen <[email-masked]>
Date: Tue, 07 Sep 2010 09:55:39 +0200

> People from Europe, Japan, Australia, and some other countries don't need a visa at all to go to an IETF meeting in the US. People from China, India and the other countries are generally backed by…

This is becoming less and less true, with the US stacking new requirements on
the visa waiver program all the time. Mandatory fingerprinting and mugshot on
each visit, having to request ESTA permission beforehand, and having to pay for
that privilege almost makes getting a real visa just as easy. Also, they do in
fact deny waivers sometimes, and once that has happened you do need a visa for
each visit (anecdotal information disclaimer: this has happened to me, and I
missed Anaheim because of it. Oh and it is definitely not a fun experience).

Another fun fact to keep in mind if visas are a part of the location decision is
that if you need a visa to enter the USA, you also need one if you have a
transfer in the USA, for instance to fly on to south america or canada.

> I would go so far as to say that getting a US visa seems easier than getting one to China. Who are the people for whom it's easier to visit a European country than it is to visit the US?

This is certainly not true. Getting a visa for china was a breeze for me. Of
course not needing one would be much better.

> On balance, I think US venues are generally better suited, and lead to less angst than either European or Asian venues. Even if they're in a cold place like Minneapolis.

I disagree, but that may not count since I'm European :)

Jelte

---

From: Dave CROCKER <[email-masked]>
Date: Mon, 06 Sep 2010 05:52:22 -0700

On 8/30/2010 1:05 PM, Patrik Fältström wrote:
> Also big corporations do have limited budget for IETF participation,

For most self-funded participants, the difference between their budget for 
travel and the budget a corporation provides is massive.  For example, the IETF 
main conference hotel is typically far above what they can afford.

On 8/30/2010 1:10 PM, Melinda Shore wrote:
 > There's already bias in the population
 > of meeting attendees - do you, and, if so, how do you account
 > for people who are already not attending because of costs?

Yes!  This is exactly the point I keep raising, about sampling error. We need to 
make sure that our analyses are with respect to the population (the full set of 
potential attendees) that we have in mind, rather than just a core of folk who 
usually attend.

A theoretical analysis of fair costs doesn't query real people, so sampling is 
not an issue.  But the second we start surveying, we need to consider folks not 
on the ietf@ or ietf-attendees@ lists.

On 8/31/2010 4:09 AM, Yoav Nir wrote:
 > One place that sucks for everybody has the great advantage of reducing the
 > stress associated with travel. A lot of people were stressed about the
 > various ways of getting to Maastricht, and a lot more are stressed about
 > getting to Beijing (what with various kinds of visas, hotels and taxi drivers
 > who don't speak any language other than Chinese)
 >
 > If we standardize on one place, then by your second meeting, you know
 > everything about the place, and people can cut&paste their complaints from
 > the previous meeting.

And to the extent that having only one place is not politically acceptable, 
having a very small number of places provides the same benefit, quickly.[1]

> On 8/30/2010 4:13 PM, Tobias Gondrom wrote:
>> 1. First, the location _is_ a significant barrier to entry for newcomers
>> and other contributors. Optimizing only for the current status quo does
>> create a strong perpetual cycle of self reinforcing structure of
>> contributors from the favored location(s).

Nicely stated.

d/

[1]  A point was raised earlier that staying with a single venue for a long time 
leads to deteriorated performance, for a variety of reasons.  The way to 
mitigate against that is to limit how long the contract is for and pursue 
competitive bidding regularly.  One of the advantages of major hub cities is 
that they have quite a bit of competition among potential meeting venues.  While 
changing hotels means learning its quirks, this is not the same as changing cities.
-- 

   Dave Crocker

---

From: Michael StJohns <[email-masked]>
Date: Tue, 07 Sep 2010 17:50:04 -0400

Dave and I don't always agree :-) 

I don't think we've got either the database of "people not attending because of costs" nor a good model for factoring them in if we did (e.g. N pnac's times some percentage who would still not attend because of other issues times some percentage where the location is problematic * etc etc).  If you can figure this out, I think you could probably apply the same model to forecasting the US stock market...

We have good data on past attendees.  From that we can probably build a pretty good model on what each past attendees Pa (percentage chance of attending the next meeting) is.  From that we can probably build a pretty good model of what our probable attendee demographics will look like absent the one-shot and/or local attendees.

Let's stick with solid data rather than try and resolve the hypotheticals - I doubt the latter is possible in any meaningful way.

Mike

At 08:52 AM 9/6/2010, Dave CROCKER wrote:
>Yes!  This is exactly the point I keep raising, about sampling error. We need to make sure that our analyses are with respect to the population (the full set of potential attendees) that we have in mind, rather than just a core of folk who usually attend.
>
>A theoretical analysis of fair costs doesn't query real people, so sampling is not an issue.  But the second we start surveying, we need to consider folks not on the ietf@ or ietf-attendees@ lists.

---

From: Michael Richardson <[email-masked]>
Date: Tue, 07 Sep 2010 21:00:33 -0400

>>>>> "Michael" == Michael StJohns <[email-masked]> writes:
    Michael> I don't think we've got either the database of "people not
    Michael> attending because of costs" nor a good model for factoring
    Michael> them in if we did (e.g. N pnac's times some percentage who

Do we at least have a list of people who attended remotely?
(I don't think so)

-- 
]       He who is tired of Weird Al is tired of life!           |  firewalls  [
]   Michael Richardson, Sandelman Software Works, Ottawa, ON    |net architect[
] [email-masked] http://www.sandelman.ottawa.on.ca/ |device driver[
   Kyoto Plus: watch the video <http://www.youtube.com/watch?v=kzx1ycLXQSE>
	               then sign the petition.

---

From: Marshall Eubanks <[email-masked]>
Date: Tue, 7 Sep 2010 21:13:41 -0400

> Do we at least have a list of people who attended remotely?

No, but we could make proxy lists (for example, people who have authored a RFC, but
not attended any meetings, in the last N years, or people who only attend meetings
in their home region, etc.). That shouldn't be too hard to do.

Marshall

---

From: Joel Jaeggli <[email-masked]>
Date: Tue, 07 Sep 2010 23:50:26 -0700

>> Do we at least have a list of people who attended remotely?

we can tell you that the peak concurrence of remote attendees on the
audio is an order of magnitude smaller than the actual concurrence (e.g.
typical peak is around 100 conccurent remote listeners). vs ~1200
attendees and 750-800 simultaneous radio associations during a busy
meeting window.

total remote attendees over the course of the week is probably higher,
but that data is a lot more ambiguous since users probably have more
than one ip address and potentially more than one user-agent over that
time frame.

data collected by the streaming servers isn't any more specific than that.

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Wed, 8 Sep 2010 18:08:08 +0200

On 8 sep 2010, at 3:13, Marshall Eubanks wrote:

> or people who only attend meetings in their home region,

Am I imagining things or are more and more American attendees foregoing meetings outside North America?

---

From: Michael Richardson <[email-masked]>
Date: Wed, 08 Sep 2010 12:48:07 -0400

>>>>> "Joel" == Joel Jaeggli <[email-masked]> writes:

    >>> Do we at least have a list of people who attended remotely?  (I
    >>> don't think so)

    Joel> we can tell you that the peak concurrence of remote attendees
    Joel> on the audio is an order of magnitude smaller than the actual
    Joel> concurrence (e.g.  typical peak is around 100 conccurent
    Joel> remote listeners). vs ~1200 attendees and 750-800 simultaneous
    Joel> radio associations during a busy meeting window.

    Joel> total remote attendees over the course of the week is probably
    Joel> higher, but that data is a lot more ambiguous since users
    Joel> probably have more than one ip address and potentially more
    Joel> than one user-agent over that time frame.

I'll bet the number of dynamic IP addresses amoung IETF remote attendees
is very small :-)

One could look at coordinating the voice session with any simultaneous
login to the datatracker.

---

From: Joel Jaeggli <[email-masked]>
Date: Wed, 08 Sep 2010 10:46:13 -0700

> I'll bet the number of dynamic IP addresses amoung IETF remote attendees

actually I think you'd be wrong, you don't have to be time shifted by
very much to switch from streaming in the office to streaming at home,
and then you get laptops versus desktops. if you sit in one location the
whole time then yeah the external ip address on your nat box is probably
stable.

> login to the datatracker.

It has been our practice to minimize the amount of date we collect, and
not associate it with other datasets that would result in being able to
uniquely identify individuals. 2 months worth of hand-wringing
discussion on the IETF list suggests that we were justified in
exercising our fiduciary responsibility in that fashion.

listener's can't contribute to the discourse except through some other
channel and don't sign the bluesheets. and since there's an archive
however poor it is they may well be timeshifted by days, hours, or years.

---

From: Dave CROCKER <[email-masked]>
Date: Fri, 10 Sep 2010 10:05:44 -0700

On 9/7/2010 2:50 PM, Michael StJohns wrote:
> I don't think we've got either the database of "people not attending because
> of costs" nor a good model for factoring them in if we did (e.g. N pnac's

Well, we agree on this.  But I class this as a failure or at least a problem, 
rather than something to accept.

> We have good data on past attendees.  From that we can probably build a
> pretty good model on what each past attendees Pa (percentage chance of

This is called selling to the installed base.  It's important to pay attention 
to the installed base of participants, but it is death for an organization to 
pay attention /only/ to that base.  It's form of incest, and really destroys the 
adaptive DNA of the organization.  Withers on the vine, loses touch with 
reality, etc. etc.

> Let's stick with solid data rather than try and resolve the hypotheticals - I
> doubt the latter is possible in any meaningful way.

My point is that we need to reach out empirically, to get input from potential 
attendees, not just from guaranteed attendees.  The fact that there is some 
challenge in identifying and contacting these new folk does not make it less 
important that we do it.

d/
-- 

   Dave Crocker