Subject: SCTP Mulithoming Communication PATHS Query

From: Sambasiva Rao Manchili <[email-masked]>
Date: Thu, 15 Apr 2010 12:30:23 +0200

Hallo,

I  have a query related to SCT Mulithoming communication paths.
Host-X: (IPpx  IPax): Multihomed Association  with Host-Y (IPpy  IPay).

Host-X  SCTP Client is running with SCTP stack provided by Vendor X
Host-Y  SCTP Server is running with SCTP stack provided by Vendor Y.

Notation.
IPpx  means IP Address of Primary  path on Host-X
IPax  means IP Address of Alternate path on Host-X

IPpy  means IP Address of Primary path on Host-Y
IPpy  means IP Address of Primary path on Host-Y

Host-X is Communicating as follows :-
-------------------------------------------------------

Primary IP  to Primary IP
Host-X(IPpx)--------HBEAT---------->Host-Y(IPpy)
Host-X(IPpx)<-------HBEAT-ACK------Host-Y(IPpy)

Alternate IP to Alternate IP
Host-X(IPax)--------HBEAT---------->Host-Y(IPay)
Host-X(IPax)<-------HBEAT-ACK------Host-Y(IPay)

/*
 * Host-X installed in Customer network.
 * Customer Network not configured/ not capable to deliver to destination
 * in the following two paths. I do not know if they have special requirement
 * to configure their network only primary talks to primary and alternate talks
 * to alternate, but I see disadvantage in their setup.
 * Host-X  keeps on trying to reach every Destination received in the
 * INIT_ACK message from Host-Y
 *
 */
Primary to Alternate Address
Host-X(IPpx)--------HBEAT---------->Host-Y(IPay) (DOES N0T REACH IPay)
Host-X(IPax)--------HBEAT---------->Host-Y(IPpy) (DOES NOT REACH IPpy)

Now Host-X was forced to configured Path Max Retransmissions and Max Init Retransmissions to value of 5, while RTO Initial and RTO MAX value is set to 1 second.
This results
1. to mark the destination endpoint IPay as NETWORK DOWN on Host-X when  it exceeds max retranmission in same path(cross) consecutively and

2. then sends INIT from IPpx to IPpy and also IPpx to IPay and as soon as it gets  the response from any destination(in customer nework only from IPpy) it is marked as NETWORK UP,

3. but soon or later we receive again NETWORK DOWN and same repeats from step 1.

Now the query is,
Is it right to tell custome Network to re-configure their network to allow
cross communication ?

OR

Is it MUST to change the Host-X stack to stop communicating Cross
i.e., IPpx trying to reach IPay.

Advantage that I see from Host-X Stack :
I also see an advantage with Host-X tranport addresses IPs trying to reach every destination
of the peer. The advantage is If the path between the  Host-Y(IPpy)  and its next hop is broken and
If the path between Host-X(IPax) and its next hop is broken still Multihoming makes real sense and
could cope up with such breakdown in network while Host-X(IPpx)------->Host-Y(IPay)

If I overlook any other disadvantage of Host-X stack, please correct me.

Looking forward for your suggestion from your expert knowledge. If something not clear please feel to ask me.
Thanks in advance.

Thanks,
samba.

Sambasiva Rao Manchili
Software Development Engineer
________________________________

NEXUS TELECOM AG
Network and Service Investigation
Muertschenstrasse 25
P.O. Box 1413
CH-8048 Zurich
Switzerland

Direct/mobile: +41 78 750 6808
Main: +41 44 355 6611
Email: [email-masked] <mailto:[email-masked]>
Website: www.nexustelecom.com<http://www.nexustelecom.com/>

________________________________
This email and any attachment may contain confidential information which is intended for use only by the addressee(s) named above. If you received this email by mistake, please notify the sender immediately, and delete the email from your system. You are prohibited from copying, disseminating or otherwise using the email or any attachment.

---

From: Xiangsong Cui <[email-masked]>
Date: Fri, 16 Apr 2010 15:14:10 +0800

Hi Samba,

It seems there is firewall between host-X and host-Y, so the cross path packets can not reach the destination?

In my understanding, some aspects may impact the result.

As far as I know, different vendors maybe provide different implementation.

some provide parallel path, like
                 (px) ----- (py)
A: host-X                           host-Y
                 (ax) ----- (ay)

while some provide both parallel and cross path, like

                  (px) ------ (py)
B:  host-X             X            host-Y
                  (ax) ------ (ay)

So, if host-Y takes implementation A, I guess the result would not change even you re-configure the network, because host-Y would 
not return HBAck in the cross path when it receives the HB message (it doesn't think the cross path is SCTP PATH), I did ever see 
such device.

But, the more important point is host-X, it looks very strange.

1. to mark the destination endpoint IPay as NETWORK DOWN on Host-X when  it exceeds max retranmission in same path(cross) 
consecutively and

If the path of IPax -- IPay is OK, this should not happen, this is the key point.
Host-X would also send HB to IPpy by the source address IPpx, and send HB to IPay by the source address IPax, and the corresponding 
HBAck would be returned by host-Y, so num of retransmission would be reset to 0. In the viewpoint of host-X, the right result should 
be: parallel paths are both OK and cross paths are both invalid, but the association should be OK.

Do you see the HB message (or DATA chunk) in the parallel path? or host-X only sends HB in the cross path?

By the way, [email-masked] is a better list for this discussion.

Regards
Xiangsong

----- Original Message ----- 
From: "Sambasiva Rao Manchili" <[email-masked]>
To: <[email-masked]>
Cc: "Antonio Gambin" <[email-masked]>; "Markus Locher" <[email-masked]>
Sent: Thursday, April 15, 2010 6:30 PM
Subject: SCTP Mulithoming Communication PATHS Query

Hallo,

Notation.

Primary IP  to Primary IP

/*

Now Host-X was forced to configured Path Max Retransmissions and Max Init Retransmissions to value of 5, while RTO Initial and RTO 
MAX value is set to 1 second.
This results
1. to mark the destination endpoint IPay as NETWORK DOWN on Host-X when  it exceeds max retranmission in same path(cross) 
consecutively and

2. then sends INIT from IPpx to IPpy and also IPpx to IPay and as soon as it gets  the response from any destination(in customer 
nework only from IPpy) it is marked as NETWORK UP,

Now the query is,

OR

Thanks,
samba.

Sambasiva Rao Manchili

NEXUS TELECOM AG

________________________________
This email and any attachment may contain confidential information which is intended for use only by the addressee(s) named above. 
If you received this email by mistake, please notify the sender immediately, and delete the email from your system. You are 
prohibited from copying, disseminating or otherwise using the email or any attachment.

--------------------------------------------------------------------------------

> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf
>

---

From: Xiangsong Cui <[email-masked]>
Date: Fri, 16 Apr 2010 15:24:44 +0800

Hi Samba,

                 (px) ----- (py)
A: host-X                           host-Y
                 (ax) ----- (ay)

                  (px) ------ (py)
B:  host-X             X            host-Y
                  (ax) ------ (ay)

Regards
Xiangsong

---

From: Sambasiva Rao Manchili <[email-masked]>
Date: Fri, 16 Apr 2010 11:03:29 +0200

Hallo Xiangsong,
Thanks a lot for the detailed mail.
>> It seems there is firewall between host-X and host-Y, so the cross path packets can not reach the destination?
There is no fire wall but two separate routers each carrying a path and these routers are not connected as well.

>> If the path of IPax -- IPay is OK, this should not happen, this is the key point.
Yes, because of this KEY point it is marked NETWROK UP in next second and again after a while(a minute or few minutes inless than 3)
that is marked NETWORK DOWN

>>Do you see the HB message (or DATA chunk) in the parallel path? or host-X only sends HB in the cross path?
HB message and DATA chuck are seen in parallel path. Host-X is sending in parallel paths and  sending also in cross intermittently. During this intermittent cross path communication once it reaches maximum number CONSECUTIVELY then immediately it marks DOWN and next second or milliseconds it marks NETWORK UP again as there is also parallel communication path attempted and succeeded.

I am asking the following question though it might not be very right to ask you, but would like to hear from your experience.
Given this situation, as I a responsible person for Host-X stack, what can be optimal values for the following parameters.
1. RTO Initial
2. Path MAX Retransmissions
3. Assoc MAX Retransmissions
4. MAX Init Retransmissions.

I do not want to stop the cross communication from Host-X(as I do not have full freedom to do that at the moment)
I can not definetly leave Host-X with values mentioned in my mail, as I get events NET DOWN for every few minutes and NET UP after few milliseconds subsequently.  With your answer, I will be in a position to convince the customer with your vast knowledge and expertise.

Best Regards
Samba.

-----Original Message-----
From: Xiangsong Cui [mailto:[email-masked]]
Sent: Friday, 16. April, 2010 09:25
To: Sambasiva Rao Manchili; [email-masked]
Cc: Antonio Gambin; Markus Locher
Subject: Re: SCTP Mulithoming Communication PATHS Query

Hi Samba,

                 (px) ----- (py)
A: host-X                           host-Y
                 (ax) ----- (ay)

                  (px) ------ (py)
B:  host-X             X            host-Y
                  (ax) ------ (ay)

So, if host-Y takes implementation A, I guess the result would not change even you re-configure the network, because host-Y would not return HBAck in the cross path when it receives the HB message (it doesn't think the cross path is SCTP PATH), I did ever see such device.

If the path of IPax -- IPay is OK, this should not happen, this is the key point.
Host-X would also send HB to IPpy by the source address IPpx, and send HB to IPay by the source address IPax, and the corresponding HBAck would be returned by host-Y, so num of retransmission would be reset to 0. In the viewpoint of host-X, the right result should
be: parallel paths are both OK and cross paths are both invalid, but the association should be OK.

Regards
Xiangsong