Subject: Ok .. I want my IETF app for my iPad ..

From: "Richard Shockey" <[email-masked]>
Date: Sat, 3 Apr 2010 17:20:54 -0400

And I want it now!  Yes I'll pay thank you.

Richard Shockey
Shockey Consulting
Chairman of the Board of Directors SIP Forum
PSTN Mobile: +1 703.593.2683
< <mailto:richard(at)shockey.us> mailto:richard(at)shockey.us>
skype: rshockey101
LinkedIn :  <http://www.linkedin.com/in/rshockey101>
http://www.linkedin.com/in/rshockey101
http//www.sipforum.org

---

From: "Richard Shockey" <[email-masked]>
Date: Sat, 3 Apr 2010 21:04:02 -0400

About 10 to 15 USD would work fine for me BTW. 

At least we should do it before the ITU and TIES does it .right?  J 

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Richard Shockey
Sent: Saturday, April 03, 2010 5:21 PM
To: [email-masked]
Subject: Ok .. I want my IETF app for my iPad ..

Richard Shockey
Shockey Consulting
Chairman of the Board of Directors SIP Forum
PSTN Mobile: +1 703.593.2683
<mailto:richard(at)shockey.us>
skype: rshockey101
LinkedIn : http://www.linkedin.com/in/rshockey101
http//www.sipforum.org

---

From: Ole Jacobsen <[email-masked]>
Date: Sat, 3 Apr 2010 18:11:03 -0700 (PDT)

And what, pray tell, does an IETF app actually do?

Generate random travel topics that we can argue about?

Display RFCs?

Doesn't this new toy of yours already have a browser?

You want emacs on it?

xml2rfc for the iPad?

A list of local restaurants in Minneapolis?

What do you want?

Ole

Ole J. Jacobsen
Editor and Publisher,  The Internet Protocol Journal
Cisco Systems
Tel: +1 408-527-8972   Mobile: +1 415-370-4628
E-mail: [email-masked]  URL: http://www.cisco.com/ipj

---

From: Dave CROCKER <[email-masked]>
Date: Sat, 03 Apr 2010 18:20:46 -0700

> And what, pray tell, does an IETF app actually do?

A squeeze of the fingers tightens a spec.

Flicking sends it to the RFC Editor.

d/
-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: Jorge Amodio <[email-masked]>
Date: Sat, 3 Apr 2010 20:51:51 -0500

> And what, pray tell, does an IETF app actually do?

The 10 commandments of the IETF in a tablet .... sort to speak.

J

---

From: Dave CROCKER <[email-masked]>
Date: Sat, 03 Apr 2010 19:32:56 -0700

> The 10 commandments of the IETF in a tablet .... sort to speak.

One commandment for each layer?

d/

-- 

   Dave Crocker

---

From: Sabahattin Gucukoglu <[email-masked]>
Date: Sun, 4 Apr 2010 04:29:24 +0100

On 4 Apr 2010, at 03:32, Dave CROCKER wrote:
> One commandment for each layer?

The layered model is obsolete, Dave.

Everybody knows the future is web 2.0, and web 2.0 is now.

Cheers,
Sabahattin

---

From: Jorge Amodio <[email-masked]>
Date: Sat, 3 Apr 2010 22:37:40 -0500

> One commandment for each layer?

We will ever get past the 8th one ?

http://www.ietf75.se/the-8th-layer-sunk-the-warship/

Cheers
Jorge

---

From: Jorge Amodio <[email-masked]>
Date: Sat, 3 Apr 2010 22:39:55 -0500

> Everybody knows the future is web 2.0, and web 2.0 is now.

Web 2.0 is also obsolete.

Since today the future is iPad, IP mobility and social media.

Cheers
Jorge

---

From: Dave CROCKER <[email-masked]>
Date: Sat, 03 Apr 2010 20:48:45 -0700

> Since today the future is iPad, IP mobility and social media.

Apparently, the iPAD is the result of an IETF bar bof:

    ietf Protocol Application Device

d/

-- 

   Dave Crocker

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 5 Apr 2010 06:38:19 +1200

Step-by-step instructions (with illustrations) for Americans to use their credit cards overseas.

On 04/04/2010, at 1:11 PM, Ole Jacobsen wrote:

> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf

--
Mark Nottingham     http://www.mnot.net/

---

From: Tim Bray <[email-masked]>
Date: Sun, 4 Apr 2010 12:48:26 -0700

> Step-by-step instructions (with illustrations) for Americans to use their credit cards overseas.

Anyhow, it has to be an iPad app, rather than iPhone/iPod-touch,
because the smaller devices can't display 80-char-66-line ASCII
properly.  -T

---

From: Julian Reschke <[email-masked]>
Date: Sun, 04 Apr 2010 21:57:37 +0200

On 04.04.2010 21:48, Tim Bray wrote:
> On Sun, Apr 4, 2010 at 11:38 AM, Mark Nottingham<[email-masked]>  wrote:

Oh, there's the killer application.

Best regards, Julian

---

From: Jorge Amodio <[email-masked]>
Date: Sun, 4 Apr 2010 15:43:25 -0500

> because the smaller devices can't display 80-char-66-line ASCII

You have not seen iSSH in action then. You can perfectly see an
80-char line, more than that damn app also has an X-server and you can
use VNC. Amazing !!!

Cheers
Jorge

---

From: Tony Finch <[email-masked]>
Date: Sun, 4 Apr 2010 21:58:56 +0100

On Sun, 4 Apr 2010, Jorge Amodio wrote:
> You have not seen iSSH in action then.

Tim's complaint is that mobile Safari's rendering of text/plain is
braindead.
Compare http://tools.ietf.org/rfc/rfc5068
with http://tools.ietf.org/html/rfc5068

Tony.
-- 
f.anthony.n.finch  <[email-masked]>  http://dotat.at/
GERMAN BIGHT HUMBER: SOUTHWEST 5 TO 7. MODERATE OR ROUGH. SQUALLY SHOWERS.
MODERATE OR GOOD.

---

From: Sabahattin Gucukoglu <[email-masked]>
Date: Sun, 4 Apr 2010 23:23:18 +0100

On 4 Apr 2010, at 21:58, Tony Finch wrote:
> with http://tools.ietf.org/html/rfc5068

Does that tool reflow the indented lines to paragraphs?  I am seeing each text section as what looks like one long pre element.

Cheers,
Sabahattin

---

From: Bill Strahm <[email-masked]>
Date: Sun, 04 Apr 2010 19:25:47 -0700

> because the smaller devices can't display 80-char-66-line ASCII
Just thinking what would happen if someone were to propose a Windows 7 
app for the IETF.  Maybe Wordpad to write those pesky ASCII I-Ds, maybe 
a meeting planner, scheduler and calendar, maybe a program to help 
organize and read all of those pesky e-mail lists.  I know someone has 
to have done something like that...

Oh wait - I'll leave you back to your regularly scheduled vendor 
specific lock-in now.

Bill (darn it - 3 days late - but I had to skip April Fools this year)

---

From: Yoav Nir <[email-masked]>
Date: Mon, 5 Apr 2010 11:28:54 +0300

On Apr 5, 2010, at 5:25 AM, Bill Strahm wrote:

> Just thinking what would happen if someone were to propose a Windows 7 app for the IETF.  Maybe Wordpad to write those pesky ASCII I-Ds, maybe a meeting planner, scheduler and calendar, maybe a program to help organize and read all of those pesky e-mail lists.  I know someone has to have done something like that...

Before discovering xml2rfc, I wrote drafts in Notepad (Wordpad can show non-ascii chars as well as pictures and stuff).

The RFC editor was a little surprised that there was no NROFF or XML source.

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Sun, 4 Apr 2010 08:10:33 -0400

It presents a chart showing the proportion of IETF-ers who have bought an iPad.

Now in theory an iPad could be very useful. Only the application I am
working on (IETF-Roulette) requires Flash.

-- 
-- 
New Website: http://hallambaker.com/
View Quantum of Stupid podcasts, Tuesday and Thursday each week,
http://quantumofstupid.com/

---

From: todd glassey <[email-masked]>
Date: Mon, 05 Apr 2010 08:37:22 -0700

> working on (IETF-Roulette) requires Flash.

is the IETF Roulette a method of demonstrating consensus in an effort?

Way cool PHB! Mechanical consensus at the touch of the "roll the dice
button" - nice.

T.

---

From: Dave Aronson <[email-masked]>
Date: Mon, 5 Apr 2010 14:18:58 -0400

> is the IETF Roulette a method of demonstrating consensus in an effort?

Maybe it matches you up with a random WG to contribute to... or worse
yet, to chair.

-Dave

-- 
Dave Aronson - Have Pun, Will Babble | Work: davearonson.com | /\ ASCII
-------------------------------------+ Play: davearonson.net | \/ Ribbon
"Specialization is for insects."     | Life: dare2xl.com     | /\ Campaign
-Robert A. Heinlein                  | Wife: nasjleti.net    | Email<>Web

---

From: Rob Evans <[email-masked]>
Date: Tue, 6 Apr 2010 17:39:57 +0100

> Doesn't this new toy of yours already have a browser?

I was idly thinking of this a few days ago.  An app for the iPad that
will sync across RFCs and I-Ds for offline viewing would be quite
useful.

Rob

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 7 Apr 2010 07:48:54 +1000

It would be even better if the Web in general could support this use case. 

The HTML5 folks are designing a client-side data store API, but alas it's not connected to the HTTP caching model, so they're effectively making Web authors rewrite their sties with JS APIs to make them usable offline -- even though HTTP already has a notion of offline cache operation. 

But now I'm ranting...

---

From: Julian Reschke <[email-masked]>
Date: Wed, 07 Apr 2010 00:01:39 +0200

> The HTML5 folks are designing a client-side data store API, but alas it's not connected to the HTTP caching model, so they're effectively making Web authors rewrite their sties with JS APIs to make…

Not yet.

I encourage everybody concerned with this (and similar "progress") to 
join the W3C HTML WG -- it's almost as open as an IETF activity.

<http://www.w3.org/html/wg/#who>

Best regards, Julian

---

From: Byron Ellacott <[email-masked]>
Date: Wed, 7 Apr 2010 09:58:55 +1000

It's not an iPad app, but you can see screenshots of the (not App Store released) IETF 77 iPhone app I threw together the week before Anaheim:

http://www.flickr.com/photos/dhask/sets/72157623658352428/

I don't have an iPad ("Late April" in Australia), but I don't think it would be terribly complex to create an app to cache I-Ds and recent mail archives per WG for reading offline.

  Byron

On 04/04/2010, at 7:20 AM, Richard Shockey wrote:

> And I want it now!  Yes I’ll pay thank you.
>  
> Richard Shockey
> Shockey Consulting

_____________________________________________________________________

Byron Ellacott                         email:           [email-masked]
Technical Area Manager, APNIC          sip:        [email-masked]
http://www.apnic.net                   phone:         +61 7 3858 3100

---

From: Vlad Ion <[email-masked]>
Date: Wed, 7 Apr 2010 14:24:51 +0300

Richard,

Here's a killer app for iPad :)

http://www.youtube.com/watch?v=lAl28d6tbko

Best regards,
Vlad Ion

IP Backbone Design Engineer
CCNP, CCIP, CCDP, CCSP

Siemens IT Solutions and Services
IT Integration & IP Planning Services
SIS SDE RO SVI BSS BPSR3

Tel.: +40 (268) 409-336
Fax: +40 (268) 409-446
mailto: [email-masked]
Mobile: +40 727 229 424
Current Time Zone : GMT + 2

On Sun, Apr 4, 2010 at 12:20 AM, Richard Shockey <[email-masked]> wrote:

> <mailto:richard(at)shockey.us <richard%28at%29shockey.us>>
> skype: rshockey101

---

From: "Richard Shockey" <[email-masked]>
Date: Thu, 8 Apr 2010 10:47:42 -0400

That was what I had in mind when I started this thread or maybe
configuration options for push of new WG drafts. 

No browser including Safari displays ASCII text well and that has been my
ultimate objection. It drives me nuts that I have to print out all new
drafts to actually read them ( sorry HP ). If the app could convert the
ASCII to something that allow for different fonts and auto repagination
display that would be totally wonderful. That function alone has been one of
the huge drivers for tablet devices as Amazon's own market analysis has
determined. Its very very age skewed to the over 40 crowd. That is why I'm
totally sold on the .epub format. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Rob
Evans
Sent: Tuesday, April 06, 2010 12:40 PM
To: Ole Jacobsen
Cc: [email-masked]
Subject: Re: Ok .. I want my IETF app for my iPad ..

Rob

---

From: Joel Jaeggli <[email-masked]>
Date: Thu, 08 Apr 2010 08:02:28 -0700

On 04/08/2010 07:47 AM, Richard Shockey wrote:
> ultimate objection.

I've got to really question what you mean by well. It's been perhaps a
decade since I printed an rfc and virtually every one of them that I've
read since has been in a browser. fwiw I use the same fixes width font
when viewing them there as I do when composing this email or editing a
draft but that's not exactly hard to achieve.

> It drives me nuts that I have to print out all new

---

From: Tony Hansen <[email-masked]>
Date: Thu, 08 Apr 2010 11:16:00 -0400

For RFCs and I-Ds, I use tools.ietf.org/html/rfc#### and 
tools.ietf.org/html/draft-XXXX. An unsung feature of that tool is that 
it both displays AND *prints properly*, using CSS to control pagination. 
(It's a workaround for what you're complaining about, but it works.)

     Tony Hansen
     [email-masked]

---

From: "Richard Shockey" <[email-masked]>
Date: Thu, 8 Apr 2010 15:56:11 -0400

Well if you are over 55 with bifocals, like me, you might have a issue. Which is why tablet readers really are a boon.

---

From: Dan York <[email-masked]>
Date: Fri, 9 Apr 2010 12:06:54 -0400

I, too, have been only using tools.ietf.org/html/* for viewing docs  
for a while and love how well it works.  Kudos to whomever put that  
site together.  The ability to jump to sections of the doc is great,  
but more so to quickly see other revs of the document or links to RFCs  
that may have updated or obsoleted the doc.  Thanks for making that  
available to all of us.

Dan

P.S. Richard, yes, EPUB is great for the eBook readers...  next I  
suppose you're going to want RFCs and I-D's in EPUB?  :-)   (And no, I  
am NOT really trying to stir up the recently concluded chapter in the  
ongoing IETF document format wars...)

On Apr 8, 2010, at 11:16 AM, Tony Hansen wrote:

> tools.ietf.org/html/draft-XXXX. An unsung feature of that tool is  
> that it both displays AND *prints properly*, using CSS to control  
> pagination. (It's a workaround for what you're complaining about,  
> but it works.)
>
>    Tony Hansen
>    [email-masked]
>

-- 
Dan York, Director of Conversations
Voxeo Corporation   http://www.voxeo.com  [email-masked]
Phone: +1-407-455-5859    Skype: danyork

Join the Voxeo conversation:
Blogs: http://blogs.voxeo.com
Twitter: http://twitter.com/voxeo  http://twitter.com/danyork
Facebook: http://www.facebook.com/voxeo

---

From: Julian Reschke <[email-masked]>
Date: Fri, 09 Apr 2010 18:17:35 +0200

On 09.04.2010 18:06, Dan York wrote:
> ...
> P.S. Richard, yes, EPUB is great for the eBook readers... next I suppose
> you're going to want RFCs and I-D's in EPUB? :-) (And no, I am NOT
> really trying to stir up the recently concluded chapter in the ongoing
> IETF document format wars...)
> ...

Source in xml2rfc format can be transformed into epub files relatively 
easily; I've got a set of scripts for this that may require some more 
tweaking and testing (I don't have an epub compatible device myself, and 
it probably needs testing for more than one device). If anybody is 
interested in trying this, feel free to email me.

Best regards, Julian

---

From: Cullen Jennings <[email-masked]>
Date: Sat, 10 Apr 2010 15:47:30 -0600

And if you shake it violently, all the discusses clear....

Seriously, I would like to have an app where I could read drafts, and make free form annotations on top of them like circling things in red, then check the annotations back into SVN or something like that were other people such as authors could sync and get my annotations. If the app could work off the xml version of the draft, it could be even nicer about inserting comments into the XML source for the draft. 

Another nice app might be something where I just flag the WGs I go to and it downloads the agenda for the meeting, gathers the drafts on the agenda, and puts them all in a "book" to read. I realize we have much of this already. 

Perhaps an app that gave you roughly all the information that is in the data tracker but could cache the data so you could use it offline on a plane. Nothing particular to the ipad on this app, but it would be a nice app to have. Seems like a great HTML5 summer project for some student. 

Cullen

PS - Is anyone working on any cool IETF related ipad apps?

> Flicking sends it to the RFC Editor.

Cullen Jennings
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: "Richard Shockey" <[email-masked]>
Date: Sun, 11 Apr 2010 12:26:24 -0400

Dan

RS> Well yes actually. My original thread was actually invite the epub folks
to hand over change control to the IETF like Jabber did with XMPP and then
we could use a document standard that was IETF anointed and reviewed. Done. 

But then we wouldn't have the annual ritual of arguing about ID RFC formats
and it just wouldn't be the IETF if we didn't do that. We have to stand for
some traditions around here however irrelevant they are.  

Though as Cullen pointed out having things that could allow tablet readers
to annotate and highlight text files like that would be a great boon and not
printing these things out all the time is a bonus.