Subject: XML2rfc and idnit

From: Ingemar Johansson S <[email-masked]>
Date: Fri, 30 Apr 2010 14:27:15 +0200

Hi

When I check one of my XML2rfc generated docsn with idnit I get the following .
====================
  Checking boilerplate required by RFC 5378 and the IETF Trust (see
  http://trustee.ietf.org/license-info):
  ----------------------------------------------------------------------------

  == You're using the IETF Trust Provisions' Section 6.b License Notice from
12
     Sep 2009 rather than the newer Notice from 28 Dec 2009.  (See
     http://trustee.ietf.org/license-info/)
==================

Currently I use trust200902, what should I change to in order to satisfy the idnit ?

/Ingemar

=================================
INGEMAR JOHANSSON  M.Sc. 
Senior Research Engineer 

Ericsson AB
Multimedia Technologies
Labratoriegränd 11
971 28, Luleå, Sweden
Phone +46-1071 43042
SMS/MMS +46-73 078 3289
[email-masked]
www.ericsson.com 
Visit http://labs.ericsson.com !
=================================

---

From: Julian Reschke <[email-masked]>
Date: Fri, 30 Apr 2010 14:48:32 +0200

On 30.04.2010 14:27, Ingemar Johansson S wrote:
> ...

1) Are you running xml2rfc 1.35, as released on March 31?

2) If you do, is your document's <date> element set to something after 
2010-03-31?

Best regards, Julian

---

From: Julian Reschke <[email-masked]>
Date: Fri, 30 Apr 2010 14:55:47 +0200

> 2) If you do, is your document's <date> element set to something after

Rephrasing...:

1) Use the latest version of xml2rfc (currently 1.35), and

2) make sure that the document's <date> is past 2010-03-31.

The @ipr attribute doesn't need to be changed.

Best regards, Julian

---

From: Ingemar Johansson S <[email-masked]>
Date: Fri, 30 Apr 2010 14:57:09 +0200

OK

I'll try that, thanks

/Ingemar 

> -----Original Message-----
> From: Julian Reschke [mailto:[email-masked]] 
> Sent: den 30 april 2010 14:56
> To: Ingemar Johansson S
> Cc: [email-masked]
> Subject: Re: XML2rfc and idnit
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 30 Apr 2010 14:57:25 +0200

Hi Ingemar,

> When I check one of my XML2rfc generated docsn with idnit I get the following .

Assuming you're using version 1.35 of xml2rfc, you should use trust200902, but
you also need to make sure that in the <date/> element you use year= and month=
to indicate a date of 2010-04-01 or later.

(This information is also available on the front page of the online xml2rfc
converters at http://xml.resource.org/ and http://tools.ietf.org/tools/xml2rfc/)

Best,

	Henrik