Subject: RE: [PWE3] Posting of IPR Disclosure related to Cisco's Statement of IPR relating to draft-ietf-pwe3-oam-msg-map-12

From: "Trowbridge, Stephen J (Steve)" <[email-masked]>
Date: Wed, 14 Apr 2010 07:47:04 -0500

Hi all,
In IEEE we are admonished to never discuss the essentiality or validity of patent claims. I cannot believe this is considered an appropriate discussion in IETF.
Regards,
Steve 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Yaakov Stein
Sent: Wednesday, April 14, 2010 1:44 AM
To: [email-masked]; [email-masked]; [email-masked]; Aissaoui, Mustapha (Mustapha); [email-masked]; Busschbach, Peter B (Peter)
Cc: [email-masked]; Secretariat; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [PWE3] Posting of IPR Disclosure related to Cisco's Statement of IPR relating to draft-ietf-pwe3-oam-msg-map-12

This disclosure (1311) quotes application US20080089227A1: Protecting multi-segment pseudowires which may impact draft-ietf-pwe3-redundancy, and perhaps ICCP, MS-PW architecture, and MS-PW setup. 
There is no apparent connection with oam-msg-map - in fact the claims stress that the triggers are failures of PSN elements (e.g. S-PEs) and are NOT from the ACs, making any connection untenable. 

A previous disclosure by the same company (863) refers to 
    20080285466 : Interworking between MPLS/IP and Ethernet OAM mechanisms which may impact mpls-eth-oam-iwk, but not oam-msg-map, unless one interprets the first claim and its dependents much more broadly than supported by the background and description.

Can someone from the company claiming this IPR fix the information in these disclosures ?
At very least that company is required to disclose IPR is holds with respect to the appropriate drafts (unless it is willing to risk forfeiting its rights with respect to these ...).

However, with respect to oam-msg-map I would like to request that it consider removing inappropriate disclosures.
Of course, if after consideration it believes that these disclosures ARE appropriate, I would love to hear the reasoning.

Y(J)S

-----Original Message-----
From: IETF Secretariat [mailto:[email-masked]]
Sent: Tuesday, April 13, 2010 18:46
To: [email-masked]; Yaakov Stein; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Posting of IPR Disclosure related to Cisco's Statement of IPR relating to draft-ietf-pwe3-oam-msg-map-12

Dear Monique Morrow, Yaakov Stein, Luca Martini, Thomas Nadeau, Mustapha Aissaoui, David Allan, Peter Busschbach:

An IPR disclosure that pertains to your Internet-Draft entitled "Pseudowire (PW) OAM Message Mapping" (draft-ietf-pwe3-oam-msg-map) was submitted to the IETF Secretariat on 2010-04-07 and has been posted on the "IETF Page of Intellectual Property Rights Disclosures" (https://datatracker.ietf.org/ipr/1311/). The title of the IPR disclosure is "Cisco's Statement of IPR relating to draft-ietf-pwe3-oam-msg-map-12."

The IETF Secretariat

_______________________________________________
pwe3 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pwe3

---

From: "Dean Willis" <[email-masked]>
Date: Thu, 15 Apr 2010 00:20:08 -0400

This was more a discussion of scope than validity.

Of course, having public discourse in a community of experts that 
disparrages the validity of a claim could bolster invalidation arguments. 
So I can see how this might be a disavored act in the IEEE community, which 
seems to be slanted towards rights holders (I speak as a long-term member 
of IEEE and as a consultant on IPR). Perhaps we'd all be better off if the 
IEEE were a little more critical of misguided claims? Regular raising of a 
hue and cry of "Bullshit!" would go a long way towards reducing the damage 
caused by unmerited patents.
 
--
Dean Willis

------- Original message -------
> From: Trowbridge, Stephen J (Steve) <[email-masked]>
> Cc: [email-masked], [email-masked], [email-masked], 
> [email-masked], [email-masked], [email-masked]
> Sent: 14.4.'10,  8:47
>
> Hi all,
> In IEEE we are admonished to never discuss the essentiality or validity 
> of patent claims. I cannot believe this is considered an appropriate 
> discussion in IETF.
> Regards,
> Steve
>
> To: [email-masked]; [email-masked]; [email-masked]; Aissaoui, 
> Mustapha (Mustapha); [email-masked]; Busschbach, Peter B 
> (Peter)
> Cc: [email-masked]; Secretariat; [email-masked]; 
> [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [PWE3] Posting of IPR Disclosure related to Cisco's 
> Statement of IPR relating to draft-ietf-pwe3-oam-msg-map-12
>
>
> This disclosure (1311) quotes application US20080089227A1: Protecting 
> multi-segment pseudowires which may impact draft-ietf-pwe3-redundancy, and 
> perhaps ICCP, MS-PW architecture, and MS-PW setup.
> There is no apparent connection with oam-msg-map - in fact the claims 
> stress that the triggers are failures of PSN elements (e.g. S-PEs) and are 
> NOT from the ACs, making any connection untenable.
>
>     20080285466 : Interworking between MPLS/IP and Ethernet OAM 
> mechanisms which may impact mpls-eth-oam-iwk, but not oam-msg-map, unless 
> one interprets the first claim and its dependents much more broadly than 
> supported by the background and description.
>
> At very least that company is required to disclose IPR is holds with 
> respect to the appropriate drafts (unless it is willing to risk forfeiting 
> its rights with respect to these ...).
>
> However, with respect to oam-msg-map I would like to request that it 
> consider removing inappropriate disclosures.
> Of course, if after consideration it believes that these disclosures ARE 
> appropriate, I would love to hear the reasoning.
>
> Y(J)S
>
>
> To: [email-masked]; Yaakov Stein; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]
> Subject: Posting of IPR Disclosure related to Cisco's Statement of IPR 
> relating to draft-ietf-pwe3-oam-msg-map-12
>
> An IPR disclosure that pertains to your Internet-Draft entitled 
> "Pseudowire (PW) OAM Message Mapping" (draft-ietf-pwe3-oam-msg-map) was 
> submitted to the IETF Secretariat on 2010-04-07 and has been posted on the 
> "IETF Page of Intellectual Property Rights Disclosures" 
> (https://datatracker.ietf.org/ipr/1311/). The title of the IPR disclosure 
> is "Cisco's Statement of IPR relating to draft-ietf-pwe3-oam-msg-map-12."
>
> The IETF Secretariat
>
>
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf
>

---

From: todd glassey <[email-masked]>
Date: Thu, 15 Apr 2010 12:00:16 -0700

> disparrages the validity of a claim could bolster invalidation

Or create a liability for the IETF and the parties involved.

> So I can see how this might be a disfavored act in the IEEE
> community, which seems to be slanted towards rights holders (I speak as
> a long-term member of IEEE and as a consultant on IPR). Perhaps we'd all
> be better off if the IEEE were a little more critical of misguided
> claims? Regular raising of a hue and cry of "Bullshit!" would go a long
> way towards reducing the damage caused by unmerited patents.

Dean - I think the problem is that the individuals in the IETF who
represent their sponsors are generally not licensed patent agents or
attorneys (although there are a couple of exceptions to this last one)
and so its really hard for someone who has no experience in the patent
process to make any reliable commentary.

The unfortunate occurance in the IETF is that people make specific
claims about what they professionally believe is and is not patentable
but the reality is that no matter what they say they are not the patent
agency or its examiners so the act of making these declarations as fact
is literally practicing law without a license IMHO. Especially when
these individuals make flat claims about the validity of a patent's
status or filing.

Individuals may have a personal opinion but I am betting that the legal
opinion of the Sponsor as to some other party's patent filing is not
something that the Sponsor's are willing to grant to their un-skilled
and non-legally trained technology players here in the IETF.

Todd Glassey

>> In IEEE we are admonished to never discuss the essentiality or
>> validity of patent claims. I cannot believe this is considered an
>> appropriate discussion in IETF.
>> Regards,
>> Steve
>>
>> To: [email-masked]; [email-masked]; [email-masked];
>> Aissaoui, Mustapha (Mustapha); [email-masked]; Busschbach,
>> Peter B (Peter)
>> multi-segment pseudowires which may impact draft-ietf-pwe3-redundancy,
>> and perhaps ICCP, MS-PW architecture, and MS-PW setup.
>> stress that the triggers are failures of PSN elements (e.g. S-PEs) and
>> are NOT from the ACs, making any connection untenable.
>>
>> mechanisms which may impact mpls-eth-oam-iwk, but not oam-msg-map,
>> unless one interprets the first claim and its dependents much more
>> broadly than supported by the background and description.
>>
>> respect to the appropriate drafts (unless it is willing to risk
>> forfeiting its rights with respect to these ...).
>>
>> Of course, if after consideration it believes that these disclosures
>> ARE appropriate, I would love to hear the reasoning.
>>
>> Y(J)S
>>
>>
>> Dear Monique Morrow, Yaakov Stein, Luca Martini, Thomas Nadeau,
>> Mustapha Aissaoui, David Allan, Peter Busschbach:
>>
>> "Pseudowire (PW) OAM Message Mapping" (draft-ietf-pwe3-oam-msg-map)
>> was submitted to the IETF Secretariat on 2010-04-07 and has been
>> posted on the "IETF Page of Intellectual Property Rights Disclosures"
>> (https://datatracker.ietf.org/ipr/1311/). The title of the IPR
>> disclosure is "Cisco's Statement of IPR relating to
>> draft-ietf-pwe3-oam-msg-map-12."
>>
>> The IETF Secretariat
>>
>>

---

From: David Morris <[email-masked]>
Date: Thu, 15 Apr 2010 13:57:53 -0700 (PDT)

> process to make any reliable commentary.

I think there are two aspects of commentary ... commenting on the legal
aspects is, as you have noted, of limited value. But commenting on the 
technical basis of a patent claim is within the realm of expertise of this
group, just as most of us have no legal standing, only some of us will be
experts for any any given issue. We can comment on prior art and we can 
comment on the question of whether a particular issue represents a 
solution that experienced practitioners in a particular technology would
come up with as an obvious solution. 

Those observations may, when taken back to our interested parties, may
stimulate proper legal process actions to object to or support a
particular patent application. The open discussion in the IETF can
make a meaningful contribution, even if the opions on their own have
no legal standing.

---

From: todd glassey <[email-masked]>
Date: Thu, 15 Apr 2010 14:50:06 -0700

On 4/15/2010 1:57 PM, David Morris wrote:
> experts for any any given issue. 

yes...  b ut not as it pertains to whether that patent will issue or
not. The issue is not whether the technology is keen or not but whether
the patent issues and nothing else is germane. The entire rest of your
rant is irrelevant in that light as well.

The novelty of the technology is the only thing that matters...

> We can comment on prior art 

yes and no... we can comment on things we believe may be prior art but
that is for the PTO's Judges and the District Court to address otherwise.

> and we can 

Sure but again - we cannot comment on whether a patent will issue
against that IP even so.

> particular patent application.

The issue may be that there is a responsibility in the representative to
take that info back to their corporate or sponsor legal officer for
review as well.

> The open discussion in the IETF can

---

From: Yaakov Stein <[email-masked]>
Date: Fri, 16 Apr 2010 11:26:45 +0300

Todd, 

My email to the PWE list and to my co-authors was neither about scope nor validity.

The trigger was an email from the IETF Secretariat informing the co-authors of draft-ietf-pwe3-oam-msg-map 
of a new IPR disclosure.
I had recently finished extensive editorial work in this draft, and in Anaheim I requested a second WG LC;
so the timing for a discussion of IPR issues related to this draft could not have been better. 

I certainly did not study the application sufficiently to be able to express an opinion as to patentability. 
I merely noted that as an co-author of the draft,
and as someone with experience in patent prosecution, 
that the disclosure was prima facie directed towards the wrong draft.

I sent the email purely as draft co-author and long-time PWE3 participant.
My employer has no direct interest in the issue.

Y(J)S 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of todd glassey
Sent: Thursday, April 15, 2010 22:00
To: [email-masked]
Subject: Re: [PWE3] Posting of IPR Disclosure related to Cisco's Statement of IPR relating to draft-ietf-pwe3-oam-msg-map-12

> So I can see how this might be a disfavored act in the IEEE community, 
> which seems to be slanted towards rights holders (I speak as a 
> long-term member of IEEE and as a consultant on IPR). Perhaps we'd all 
> claims? Regular raising of a hue and cry of "Bullshit!" would go a 
> long way towards reducing the damage caused by unmerited patents.

Dean - I think the problem is that the individuals in the IETF who represent their sponsors are generally not licensed patent agents or attorneys (although there are a couple of exceptions to this last one) and so its really hard for someone who has no experience in the patent process to make any reliable commentary.

The unfortunate occurance in the IETF is that people make specific claims about what they professionally believe is and is not patentable but the reality is that no matter what they say they are not the patent agency or its examiners so the act of making these declarations as fact is literally practicing law without a license IMHO. Especially when these individuals make flat claims about the validity of a patent's status or filing.

Individuals may have a personal opinion but I am betting that the legal opinion of the Sponsor as to some other party's patent filing is not something that the Sponsor's are willing to grant to their un-skilled and non-legally trained technology players here in the IETF.

Todd Glassey

>> Aissaoui, Mustapha (Mustapha); [email-masked]; 
>> Busschbach, Peter B (Peter)
>> multi-segment pseudowires which may impact 
>> draft-ietf-pwe3-redundancy, and perhaps ICCP, MS-PW architecture, and MS-PW setup.
>> stress that the triggers are failures of PSN elements (e.g. S-PEs) 
>> and are NOT from the ACs, making any connection untenable.
>>
>> Subject: Posting of IPR Disclosure related to Cisco's Statement of 
>> IPR relating to draft-ietf-pwe3-oam-msg-map-12
>>

---

From: Donald Eastlake <[email-masked]>
Date: Thu, 15 Apr 2010 14:56:46 -0400

There is no such rule in the IETF, although perhaps patent discussions
need some moderation to avoid becoming ratholes. To quote some pieces
of text from RFC 3669 (which I recommend you read in full):

"It's all right, and sometimes beneficial, to discuss IPR claims
      and gather information about possible prior art on the [working]
group list.
      The results of such discussion can be considered when deciding
      whether to develop a technology (but remember that neither the
      IETF nor any working group takes a stand on such claims as a body,
      and the group is not the best place to get legal advice)."

and

"Working group participants can evaluate IPR claims not only for
      their possible validity, but also for the risk of misjudging that
      validity."

Donald
=============================
 Donald E. Eastlake 3rd
 155 Beaver Street
 Milford, MA 01757 USA

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Fri, 16 Apr 2010 00:31:20 -0400

ObDeclaration: I am also a practitioner in this field.

I see no problem with people making purely factual claims such as
'Document X may constitute prior art with respect to some of the
claims'.

Making conclusions is where the problem might lie, if that is someone
was foolish enough to consider commentary in this forum to be a
reliable form of advice or that either the IETF or the poster had any
duty of care with respect to the advice given.

Construing patent claims is not as straightforward as it might appear
at first sight.

-- 
-- 
New Website: http://hallambaker.com/
View Quantum of Stupid podcasts, Tuesday and Thursday each week,
http://quantumofstupid.com/

---

From: Yaakov Stein <[email-masked]>
Date: Fri, 16 Apr 2010 10:53:07 +0300

In the IETF meta-discussions on the idea of discussing IPR are more liable to become ratholes than the IPR discussion itself.
Even worse is the meta-meta discussion on whether to restrict ourselves to using ASCII in the meta-discussion :)

IPR SHOULD be discussed by the WG, and this discussion is especially appropriate during the LC period of a standards track draft 
( we asked for a 2nd LC on this draft ) in order to understand any possible issues before passing on to the IESG.

In some WGs (e.g. codec) IPR issues are more important than others as their mission is to create technology
which is as IPR-free as possible. In codec's case they have even appointed someone specifically to check into IPR
(from a technical point of view - to make sure that disclosures have been made - not to "rule" on IPR). 

In PWE there have been a plethora of patents from the start, but everything has always been disclosed and discussed.
It would be unfortunate for things to become confused due to technical errors of disclosing with respect to the wrong drafts.

Y(J)S

-----Original Message-----
From: Donald Eastlake [mailto:[email-masked]] 
Sent: Thursday, April 15, 2010 21:57
To: Trowbridge, Stephen J (Steve)
Cc: Yaakov Stein; [email-masked]; [email-masked]; [email-masked]; Aissaoui, Mustapha (Mustapha); [email-masked]; Busschbach, Peter B (Peter); Secretariat; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [PWE3] Posting of IPR Disclosure related to Cisco's Statement of IPR relating to draft-ietf-pwe3-oam-msg-map-12

and

Donald