Subject: Re: Last Call: draft-weiler-rsync-uri (The rsync URI Scheme) to Informational RFC

From: Ted Hardie <[email-masked]>
Date: Wed, 30 Sep 2009 12:18:06 -0700

Just out of curiousity, why is this registering it as provisional,
rather than permanent scheme?

Also, I didn't see any discussion about this on uri-review.  This may
be because it dropped during my recent mailbox moves, but if it hasn't
been seen there it might be a reasonable idea.  Support for a
permanent registration might even emerge there.

regards,

Ted

On Wed, Sep 30, 2009 at 7:31 AM, The IESG <[email-masked]> wrote:
> The IESG has received a request from an individual submitter to consider
> the following document:
>
> - 'The rsync URI Scheme '
>   <draft-weiler-rsync-uri-01.txt> as an Informational RFC
>
> The IESG plans to make a decision in the next few weeks, and solicits
> final comments on this action.  Please send substantive comments to the
> [email-masked] mailing lists by 2009-10-28. Exceptionally,
> comments may be sent to [email-masked] instead. In either case, please
> retain the beginning of the Subject line to allow automated sorting.
>
> The file can be obtained via
> http://www.ietf.org/internet-drafts/draft-weiler-rsync-uri-01.txt
>
>
> IESG discussion can be tracked via
> https://datatracker.ietf.org/public/pidtracker.cgi?command=view_id&dTag=18880&rfc_flag=0
>
> _______________________________________________
> IETF-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-announce
>

---

From: Russ Housley <[email-masked]>
Date: Wed, 30 Sep 2009 15:51:14 -0400

>rather than permanent scheme?

There is not a rsync protocol specification and URI scheme.  The 
protocol is widely deployed.  In fact the IETF depends on it 
everyday.  This document is intended to provide a citable 
specification for the URL scheme, but not the protocol.  Without the 
protocol specification, provisional seemed like the best choice based 
on RFC 4395.

Russ

---

From: Eliot Lear <[email-masked]>
Date: Wed, 30 Sep 2009 22:08:02 +0200

Russ,

I think the point is that the IESG should probably refer the doc to the
uri-review team to look for any red flags.  Mistakes in URI specs are
common (speaking has one that has made some).

Eliot

On 9/30/09 9:51 PM, Russ Housley wrote:
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf
>

---

From: Ted Hardie <[email-masked]>
Date: Wed, 30 Sep 2009 16:41:56 -0700

On Wed, Sep 30, 2009 at 12:51 PM, Russ Housley <[email-masked]> wrote:
> There is not a rsync protocol specification and URI scheme.  The protocol is
> widely deployed.  In fact the IETF depends on it everyday.  This document is
> intended to provide a citable specification for the URL scheme, but not the
> protocol.  Without the protocol specification, provisional seemed like the
> best choice based on RFC 4395.
>

Fair enough; thanks for the explanation.  I think adding something to
the IANA considerations documenting that logic couldn't hurt, e.g:

"A provisional registration is being sought as there is no citable
rsync protocol specification at this time, despite its widespread
deployment".

regards,

Ted Hardie

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 30 Sep 2009 18:33:14 -0700

>rsync protocol specification at this time, despite its widespread

+1

--Paul Hoffman, Director
--VPN Consortium