Subject: Re: Should not URIs be resources and not actions

From: Eric Burger <[email-masked]>
Date: Mon, 02 Jul 2007 13:08:06 -0400

Because the scheme name is just a bunch of octets before the colon that has
no meaning except for the meaning we humans agree to give it.

Why "callto:" instead of "tel:" instead of "telefon:"?  What you point out
is what is important: what is standard or at least de facto standard.

[From your example, is Skype purposely trying to not use ANY IETF
standards?]

Changing any of the schemes that is supported by lots of applications is not
going to be a successful exercise.

On 6/30/07 4:17 PM, "Daniel Aleksandersen" <[email-masked]>
wrote:

> Hi,
> 
> "Uniform Resource Identifier schemas describe resources. Why then are some
> of the themost popular URIs schemas named as actions?
> 
> mailto: is an action, whilst email: is a resource. The first is the standard
> and widely supported, and the second is not the standard and is not
> supported by a single application.
> 
> Another example:
> tel: is a resource, whilst callto: is an action. The second is supported by
> Skype (a popular calling software) but is not a standard, and the first is
> the standard but not supported by a single application.
> 
> To me it looks like calling users to actions is more important than pointing
> out the appropriate resource. Which is not the point of an URI.
> 
> Am I missing something here? Where did it all go wrong?.."
> 
> Question originally asked in my blog:
> http://thewebdesignjournal.com/2007/06/uri-schemas-are-dead/
> 
> What I mean to say: Should not the mailto URI schema be renamed email or
> something?.. Or why is it named the way it is?

Notice:  This email message, together with any attachments, may contain information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated entities,  that may be confidential,  proprietary,  copyrighted  and/or legally privileged, and is intended solely for the use of the individual or entity named in this message. If you are not the intended recipient, and have received this message in error, please immediately return this by email and then delete it.

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Mon, 2 Jul 2007 13:52:06 -0700

> From: Daniel Aleksandersen [mailto:[email-masked]] 

> Hi,
> 
> "Uniform Resource Identifier schemas describe resources. Why 
> then are some of the themost popular URIs schemas named as actions?
> 
> mailto: is an action, whilst email: is a resource. The first 
> is the standard and widely supported, and the second is not 
> the standard and is not supported by a single application.
> 
> Another example:
> tel: is a resource, whilst callto: is an action. The second 
> is supported by Skype (a popular calling software) but is not 
> a standard, and the first is the standard but not supported 
> by a single application.

The reason is historical, nothing more.

The tag mailto was used to differentiate a mail message from the action of sending a mail. At the time we had a somewhat functional view of the web and uris. Mailto was actually implemented by running a script via termcap.

There is something of a case that can be made for differentiating the mode of communiction: mailto, jabberto etc. Mailto can take a subject argument for instance. But its not a case I would argue for myself. The parameters are much better handled in other ways. The mailto URI should be regarded as a generalized contact identifier for a person or a group of people.

---

From: Masataka Ohta <[email-masked]>
Date: Tue, 03 Jul 2007 07:52:11 +0900

> of the themost popular URIs schemas named as actions?

Because URIs without locators accessible through networks are
useless, all the popular URIs are URLs, which describes not
resources but how to "access" resources, which are actions.

> the standard but not supported by a single application.

Thanks to IETF attempts to dictate the Internet by making IANA
registration unreasonably difficult, people began to ignore
IANA.

						Masataka Ohta