Subject: e2e

From: John Kristoff <[email-masked]>
Date: Thu, 26 Jul 2007 18:20:12 -0500

Responding to something just overheard in the plenary...

No, it's not about complexity, but nor is it about robustness.  It's about
"functionality" and where to place it.  A simple word search should help
highlight this point.

I'm a bit surprised I'm contradicting some who I have a great deal of
respect and are most assuredly much more well known within the IETF than
I.  It either signals something fundamentally wrong with the IETF or,
much more likely, me.  :-)

Perhaps all participants can commit to a twice careful read of the original
paper that gets referred to so much before the next IETF?

John

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Scott Brim <[email-masked]>
Date: Thu, 26 Jul 2007 19:37:10 -0400

> "functionality" and where to place it.  A simple word search should help

I'm not there this time but ... where you place functionality has a
direct impact on complexity and robustness.  Could it be that whoever
it was was making an inference?

---

From: Lixia Zhang <[email-masked]>
Date: Thu, 26 Jul 2007 18:00:50 -0700

On Jul 26, 2007, at 4:37 PM, Scott Brim wrote:

> direct impact on complexity and robustness.

Scott is right.  Where to place functionality has an impact on  
complexity, in addition to robustness.

BTW for everyone's convenience, here are the pointers to the two  
Clark papers mentioned:

"End-to-End arguments in System Design"
ACM Transactions in Computer Systems 2, 4, November, 1984
http://web.mit.edu/Saltzer/www/publications/endtoend/endtoend.pdf

"The Design Philosophy of the DARPA Internet Protocols"
http://nms.csail.mit.edu/6829-papers/darpa-internet.pdf
SIGCOMM '88

> Could it be that whoever

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Thu, 26 Jul 2007 20:47:16 -0700

The bigger point I was making was that we are not a religious organization. We do not have sacred texts, we do not proceed by performing exegesis.

In particular note: "Thus the end-to-end argument is not an absolute rule, but rather a guideline that helps in application and protocol design analysis; one must use some care to identify the end points to which the argument should be applied."

I don't think that I am misrepresenting the paper when I sumarize it as saying 'keep the complexity out of the network core'. As I read the paper that is at the very heart of the argument. 

If you like s/complexity/as much functionality as you can/ 

This is a core principle in the design of XKMS, SAML and other Web Service based protocols. The endpoints of a trust relationship are people and organizations, not machines. As Adi Shamir put it at this years RSA conference 'Alice and Bob are not Turing machines'.

The real world is complex: we can't eliminate the complexity but we can choose where we manage it.

The paper considers two options, complexity at the end points vs complexity in the network. The idea of the network edge as being a third option is not really considered as an alternative.

End to end is not the same thing as host to host.

> -----Original Message-----
> From: John Kristoff [mailto:[email-masked]] 
> Sent: Thursday, July 26, 2007 7:20 PM
> To: [email-masked]
> Subject: e2e
> 
> No, it's not about complexity, but nor is it about 
> robustness.  It's about "functionality" and where to place 
> it.  A simple word search should help highlight this point.
> 
> I'm a bit surprised I'm contradicting some who I have a great 
> deal of respect and are most assuredly much more well known 
> within the IETF than I.  It either signals something 
> fundamentally wrong with the IETF or, much more likely, me.  :-)
> 
> Perhaps all participants can commit to a twice careful read 
> of the original paper that gets referred to so much before 
> the next IETF?
> 
> John
>

---

From: "Steven M. Bellovin" <[email-masked]>
Date: Fri, 27 Jul 2007 00:37:45 -0400

But I should point people at RFC 4924.  (No, I won't try to summarize
it.)

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 27 Jul 2007 14:36:49 +0200

> But I should point people at RFC 4924.  (No, I won't try to summarize

Not forgetting RFC 1958, of course.

    Brian