Subject: Multi-services network

From: "Constantine Protopapas" <[email-masked]>
Date: Sat, 17 Apr 1999 19:28:59 +0300

I am in the designing stage for a multiservice network integrating real-time
data (Real Audio, stock exchange data), voice (in the near future) and
Internet services (e-mail, FTP, http etc.). I would like to get some
opinions and feedback from you based on your experience. More to the point,
I am looking of possible ways to achieve end-to-end QoS. Since I am not
budget-constrained, I look for the best possible solution. I am thinking of
using ATM at the core/backbone and TCP/IP on the edge. Conversely, I could
use an all-IP environment, but I don't know if QoS can be implemented
adequately for the applications required. The reason for this posting is to
ask about the different technologies involved, especially in the QoS area.
Thank you in advance for your co-operation and assistance.

Constantine Protopapas
Systems/Network Engineer
Wiztech Internet Consulting
e-mail:	[email-masked]
Tel:	++301-6801391

---- STOP THE WAR IN YUGOSLAVIA ----

---

From: Kevin Tucker <[email-masked]>
Date: Sat, 17 Apr 1999 11:50:12 -0500

If price is not a consideration, ATM is the hands-down choice for the
backbone of this application (in my humble opinion).  

First, let's discuss why IP is a good choice, but not a great choice:

*	QoS is not "there" just yet...gigabit QoS is claimed, but still a
ways off compared to the ATM solutions
*	Gigabit ethernet standards are only emerging, quite new, and
relatively untested compared to ATM
*	IP Voice is a featureless voice system, as opposed to using a PBX
over ATM.  Try to do three-way calling, message waiting lights, etc. over IP
voice.  It's just not there yet.

Now, why ATM is the solution of choice:

*	ATM is nearly infinitely scalable.  While you do not discuss your
bandwidth needs per se, you can go anywhere from OC-3 on up to OC-192 (if
budget really isn't an issue) and anywhere in between.  
*	ATM runs T-1 circuit emulation for voice-creating QoS and an easy
interface for most newer PBXs.
*	PVCs create application-specific QoS for video, audio, or other
applications
*	Data still runs great over even a truncated OC-3 circuit
*	If one of the distribution points if off-site, most Telcos or other
service providers will offer leased ATM circuits...very few offer IP...and
you want to maintain consistency throughout the enterprise.

Just my thoughts...

Kevin Tucker
MIS Labs
www.mislabs.com <http://www.mislabs.com> 

		-----Original Message-----
		From:	Constantine Protopapas
[mailto:[email-masked]]
		Sent:	Saturday, April 17, 1999 11:29 AM
		To:	[email-masked]
		Cc:	Scott Brim
		Subject:	Multi-services network

		I am in the designing stage for a multiservice network
integrating real-time data (Real Audio, stock exchange data), voice (in the
near future) and Internet services (e-mail, FTP, http etc.). I would like to
get some opinions and feedback from you based on your experience. More to
the point, I am looking of possible ways to achieve end-to-end QoS. Since I
am not budget-constrained, I look for the best possible solution. I am
thinking of using ATM at the core/backbone and TCP/IP on the edge.
Conversely, I could use an all-IP environment, but I don't know if QoS can
be implemented adequately for the applications required. The reason for this
posting is to ask about the different technologies involved, especially in
the QoS area.
		Thank you in advance for your co-operation and assistance.

		Constantine Protopapas
		Systems/Network Engineer

		---- STOP THE WAR IN YUGOSLAVIA ----

---

From: "Reni Ninan" <[email-masked]>
Date: Sat, 17 Apr 1999 14:05:10 -0400

Constatine,

It depends on 2 major factors 1) when you plan to implement the network and
2) do you have bandwidth constraints? If it's going to be a year or two,
then IP alone will work as well. With MPLS just being ratified, IP services
will also be able to support QoS. But if it's going to be now, then IP is
just not yet there yet. Especially with Voice, you will hard pressed to get
the quality that you might get with ATM (Granted a lot depends on the
algorithms that the vendors implement, CS-ACELP, ADPCM etc.).

ATM QoS is already proven.

I think, currently the better choice is IP at the edge and ATM at the core.

Thanks
                    - Reni

----------------------------------------------------------------------- 
Reni Ninan 
* Tel: 847-706-8461 
*    Fax: 847-706-8468 
* E-Mail: <mailto:[email-masked]>

> From:	Constantine Protopapas [mailto:[email-masked]]
> To:	ietf
> I am in the designing stage for a multiservice network integrating
> real-time data (Real Audio, stock exchange data), voice (in the near
> future) and Internet services (e-mail, FTP, http etc.). I would like to
> the point, I am looking of possible ways to achieve end-to-end QoS. Since
> I am not budget-constrained, I look for the best possible solution. I am
> be implemented adequately for the applications required. The reason for
> this posting is to ask about the different technologies involved,
> especially in the QoS area.

---

From: Avijeet Mukherjee <[email-masked]>
Date: Tue, 20 Apr 1999 13:29:47 +0530

my humble comments ::

ATM is definetely the choice if cost is not a matter .but the problem is
that end ot end QOS ( from desktop to desktop ) is not possible. The problem
is primarly because the edge desktops can have 802.1p but there is not
correlation between this and the ATM SVCs or RSVP to ATM Qos .

the mapping of RSVP to ATM QOS becomes important when end t end QOS is
important . ATM QOS is ages ahead of the QOS given by IP . However , for
data apps IP precedence with WFQ and WRED may help u .

	----------
	From: 	Kevin Tucker[SMTP:[email-masked]]
	Sent: 	Saturday, April 17, 1999 10:20 PM
	To: 	'Constantine Protopapas'; [email-masked]
	Cc: 	Scott Brim
	Subject: 	RE: Multi-services network

	If price is not a consideration, ATM is the hands-down choice for
the
	backbone of this application (in my humble opinion).  

	First, let's discuss why IP is a good choice, but not a great
choice:

	*	QoS is not "there" just yet...gigabit QoS is claimed, but
still a
	ways off compared to the ATM solutions
	*	Gigabit ethernet standards are only emerging, quite new, and
	relatively untested compared to ATM
	*	IP Voice is a featureless voice system, as opposed to using
a PBX
	over ATM.  Try to do three-way calling, message waiting lights, etc.
over IP
	voice.  It's just not there yet.

	*	ATM is nearly infinitely scalable.  While you do not discuss
your
	bandwidth needs per se, you can go anywhere from OC-3 on up to
OC-192 (if
	budget really isn't an issue) and anywhere in between.  
	*	ATM runs T-1 circuit emulation for voice-creating QoS and an
easy
	interface for most newer PBXs.
	*	PVCs create application-specific QoS for video, audio, or
other
	applications
	*	Data still runs great over even a truncated OC-3 circuit
	*	If one of the distribution points if off-site, most Telcos
or other
	service providers will offer leased ATM circuits...very few offer
IP...and
	you want to maintain consistency throughout the enterprise.

	Just my thoughts...

	Kevin Tucker
	MIS Labs

			-----Original Message-----
			From:	Constantine Protopapas
	[mailto:[email-masked]]
			Sent:	Saturday, April 17, 1999 11:29 AM
			To:	[email-masked]
			Cc:	Scott Brim
			Subject:	Multi-services network

			I am in the designing stage for a multiservice
network
	integrating real-time data (Real Audio, stock exchange data), voice
(in the
	near future) and Internet services (e-mail, FTP, http etc.). I would
like to
	get some opinions and feedback from you based on your experience.
More to
	the point, I am looking of possible ways to achieve end-to-end QoS.
Since I
	am not budget-constrained, I look for the best possible solution. I
am
	thinking of using ATM at the core/backbone and TCP/IP on the edge.
	Conversely, I could use an all-IP environment, but I don't know if
QoS can
	be implemented adequately for the applications required. The reason
for this
	posting is to ask about the different technologies involved,
especially in
	the QoS area.
			Thank you in advance for your co-operation and
assistance.

			Constantine Protopapas
			Systems/Network Engineer

			---- STOP THE WAR IN YUGOSLAVIA ----

---

From: "Reni Ninan" <[email-masked]>
Date: Tue, 20 Apr 1999 13:10:48 -0400

If you only choice is IP only, then you should look at 802.1p/RSVP. These
are not yet widely implemented though, but in 6 months to a year you should
see progress. The problem is though in  retaining the QoS profiles outside
of your private network, once it goes into a public network. Would they
support those traffic profiles? Not right now.

                    - Reni

-----Original Message-----
From: Constantine Protopapas [mailto:[email-masked]]
Sent: Saturday, April 17, 1999 3:51 PM
To: Kevin Tucker; Ninan, Reni [SCH:9236:EXCH]
Cc: ietf
Subject: RE: Multi-services network

Implementation timeline is 6 months-1 year. I tend to agree with your
proposed solution (IP on the edge and ATM on the core). There is a very big
stumbling block: ATM in Greece is still in pilot trial; there are only 3 ATM
nodes and all 3 are in educational institutions. At this point in time the
whole ATM project is stopped for lack of interoperability. The solution of
pure IP, although it's not the best one, seems the only one under the
present circumstances.

Constantine Protopapas
Systems/Network Engineer

---	"...Fear leads to anger, anger leads to hate, hate leads to
suffering..."
	STOP THE KILLING IN YUGOSLAVIA!!

-----Original Message-----
From: Reni Ninan [mailto:[email-masked]]
Sent: ???????, 17 ???????? 1999 9:05 ??
To: Constantine Protopapas; ietf
Cc: Scott Brim
Subject: RE: Multi-services network

Constatine,

Thanks
                    - Reni

---

From: Avijeet Mukherjee <[email-masked]>
Date: Tue, 20 Apr 1999 13:29:47 +0530

my humble comments ::

	----------

	Just my thoughts...

	Kevin Tucker
	MIS Labs

			-----Original Message-----
			From:	Constantine Protopapas
	[mailto:[email-masked]]
			Sent:	Saturday, April 17, 1999 11:29 AM
			To:	[email-masked]
			Cc:	Scott Brim
			Subject:	Multi-services network

			Constantine Protopapas
			Systems/Network Engineer

			---- STOP THE WAR IN YUGOSLAVIA ----

--KAA13891.924597792/Cirdan.KryptoKom.DE--

---

From: Avijeet Mukherjee <[email-masked]>
Date: Tue, 20 Apr 1999 13:29:47 +0530

my humble comments ::

	----------

	Just my thoughts...

	Kevin Tucker
	MIS Labs

			-----Original Message-----
			From:	Constantine Protopapas
	[mailto:[email-masked]]
			Sent:	Saturday, April 17, 1999 11:29 AM
			To:	[email-masked]
			Cc:	Scott Brim
			Subject:	Multi-services network

			Constantine Protopapas
			Systems/Network Engineer

---

From: "Reni Ninan" <[email-masked]>
Date: Tue, 20 Apr 1999 13:10:48 -0400

- Reni

-----Original Message-----
From: Constantine Protopapas [mailto:[email-masked]]
Sent: Saturday, April 17, 1999 3:51 PM
To: Kevin Tucker; Ninan, Reni [SCH:9236:EXCH]
Cc: ietf
Subject: RE: Multi-services network

Constantine Protopapas
Systems/Network Engineer

-----Original Message-----
From: Reni Ninan [mailto:[email-masked]]
Sent: ???????, 17 ???????? 1999 9:05 ??
To: Constantine Protopapas; ietf
Cc: Scott Brim
Subject: RE: Multi-services network

Constatine,

Thanks
                    - Reni

---

From: "Reni Ninan" <[email-masked]>
Date: Tue, 20 Apr 1999 13:10:48 -0400

- Reni

-----Original Message-----
From: Constantine Protopapas [mailto:[email-masked]]
Sent: Saturday, April 17, 1999 3:51 PM
To: Kevin Tucker; Ninan, Reni [SCH:9236:EXCH]
Cc: ietf
Subject: RE: Multi-services network

Constantine Protopapas
Systems/Network Engineer

-----Original Message-----
From: Reni Ninan [mailto:[email-masked]]
Sent: ???????, 17 ???????? 1999 9:05 ??
To: Constantine Protopapas; ietf
Cc: Scott Brim
Subject: RE: Multi-services network

Constatine,

Thanks
                    - Reni

---

From: Irwin Lazar <[email-masked]>
Date: Wed, 21 Apr 1999 13:12:48 -0400

Hi All,
I disagree with the statement that ATM is the hands-down choice for backbone
connectivity.  Packet over SONET or Gigabit Ethernet, coupled with
prioritization techniques such as WRED and WFQ can offer acceptable
performance for most applications in the LAN/Campus environment.  End-to-end
IP QoS will soon be possible via RSVP and Diff-Serv signaling, not to
mention MPLS.  

Irwin

---------
Irwin Lazar - [email-masked] 
Network Analyst
NetReference, Inc. (Formerly Decisys, Inc.)
45615 Willow Pond Plaza
Sterling, VA 20164
(703)742-9659 Voice
(703)742-8038 Fax
Visit us @ http://www.netreference.com/
NetReference - The Ultimate Resource for Network Architects

> From: Avijeet Mukherjee [mailto:[email-masked]]
> Sent: Tuesday, April 20, 1999 4:00 AM
> To: 'Constantine Protopapas'; [email-masked]; 'Kevin Tucker'
> Cc: Scott Brim

---

From: Avijeet Mukherjee <[email-masked]>
Date: Tue, 20 Apr 1999 13:29:47 +0530

my humble comments ::

	----------

	Just my thoughts...

	Kevin Tucker
	MIS Labs

			-----Original Message-----
			From:	Constantine Protopapas
	[mailto:[email-masked]]
			Sent:	Saturday, April 17, 1999 11:29 AM
			To:	[email-masked]
			Cc:	Scott Brim
			Subject:	Multi-services network

			Constantine Protopapas
			Systems/Network Engineer

---

From: Avijeet Mukherjee <[email-masked]>
Date: Tue, 20 Apr 1999 13:29:47 +0530

my humble comments ::

	----------

	Just my thoughts...

	Kevin Tucker
	MIS Labs

			-----Original Message-----
			From:	Constantine Protopapas
	[mailto:[email-masked]]
			Sent:	Saturday, April 17, 1999 11:29 AM
			To:	[email-masked]
			Cc:	Scott Brim
			Subject:	Multi-services network

			Constantine Protopapas
			Systems/Network Engineer

---

From: "Reni Ninan" <[email-masked]>
Date: Wed, 21 Apr 1999 13:32:43 -0500

I only sent it once, but I got at least 6 copies of Avijeet' e-mail as well.
May be something wrong with the mail server.

                    - Reni

-----Original Message-----
From: Satpute. Madhavi [mailto:[email-masked]]
Sent: Wednesday, April 21, 1999 1:15 PM
To: Ninan, Reni [SCH:9236:EXCH]
Cc: Constantine Protopapas; Kevin Tucker; ietf
Subject: RE: Multi-services network

Why are you sending the same mail again and again?

> I think, currently the better choice is IP at the edge and ATM at the
core.
Since

---

From: "Reni Ninan" <[email-masked]>
Date: Wed, 21 Apr 1999 13:32:43 -0500

- Reni

-----Original Message-----
From: Satpute. Madhavi [mailto:[email-masked]]
Sent: Wednesday, April 21, 1999 1:15 PM
To: Ninan, Reni [SCH:9236:EXCH]
Cc: Constantine Protopapas; Kevin Tucker; ietf
Subject: RE: Multi-services network

Since